Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a thesis and I'd like to use the openright option:

\documentclass[letterpaper,12pt,twoside,openright]{report}

The problem is that when I use this option, empty pages are placed between different sections of the preface. i.e. abstract - empty page - table of contents - list of figures - empty page - list of tables... etc.

I looked at the thesis.sty provided by my department and I noticed that each section of the preface are formatted to behave like chapters.

\def\prefacesection#1{
    \chapter*{#1} 
    \addcontentsline{toc}{chapter}{#1}}

I tried changing this code snippet so that sections of the preface are actually treated as sections

\def\prefacesection#1{
    \section*{#1} 
    \addcontentsline{toc}{chapter}{#1}}

Although this removed the empty pages, I was disappointed with the results. Firstly, the ToC, LoF, and LoT were not affected by this change (I assume their style is defined elsewhere). Secondly, I strongly preferred the look and style as it was before I made any changes to the preface style.

Is there anyway I can selectively apply the openright option so that the contents of the preface are unaffected? Or is there a better way to fix my problem with empty pages in the preface?

share|improve this question
    
The toc line is styled by the code you showed if you changed chapter to section it would be styled like a section in teh table of contents –  David Carlisle Mar 25 at 21:10
    
@DavidCarlisle When I wrote that the ToC, LoF and LoT were unaffected, I wasn't referring to the ToC line. I was referring to the appearance of the actual pages themselves. –  socratic Mar 25 at 23:33
add comment

1 Answer 1

up vote 6 down vote accepted

The toc line is styled by the code you showed: if you changed chapter to section it would be styled like a section in the table of contents

you can switch openright styles in your frontmatter using

\csname @openrightfalse\endcsname

and

\csname @openrighttrue\endcsname
share|improve this answer
    
Thank you for your help! –  socratic Mar 25 at 23:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.