Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've been trying to use this post to create a bibliography (natbib: use the harvard referencing system) but am receiving the error .bbl' not created by bib latex.

My .tex file

\documentclass{article}

\usepackage[style=authoryear,backend=biber]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage{filecontents,hyperref}

\title{Assignment \#1}
\author{}
\date{March 29, 2014}


\begin{filecontents}{bibtest.bib}
@online{zappone2009supermarketduopoly,
author = {Zappone, C.},
title = {Supermarket duopoly blamed for soaring food prices},
year = {2009}, 
url = {http://www.smh.com.au/business/supermarket-duopoly-blamed-for-soaring-food-    prices-20091109-i3tn.html},
urldate = {2014-29-03}
}

\end{filecontents}

\bibliography{bibtest}


\begin{document}


\maketitle    

\section*{Question 1}

\subsection*{Woolworths}

\textit{Core Business:}

\parencite{zappone2009supermarketduopoly}.




\printbibliography

\end{document}

Would anyone know what the problem is?

Thank you for your help.

share|improve this question
    
On first sight, you just have to do another run of biber. –  Johannes_B Mar 29 at 11:23

2 Answers 2

up vote 6 down vote accepted

The .bbl files created by a normal BibTeX run and a Biber run (or BibTeX with biblatex) are completely different and they are not compatible with each other.

Surely you've used a file where a "normal" bibliography was used and afterwards you've switched to biblatex.

That's why biblatex is complaining that the .bbl file has not been created by it.

The solution is to delete the .bbl file and run pdflatex and Biber again.

This is the contents of the .bbl file generated by biblatex with Biber from your bibliography:

% $ biblatex auxiliary file $
% $ biblatex bbl format version 2.3 $
% Do not modify the above lines!
%
% This is an auxiliary file used by the 'biblatex' package.
% This file may safely be deleted. It will be recreated by
% biber as required.
%
\begingroup
\makeatletter
\@ifundefined{ver@biblatex.sty}
  {\@latex@error
     {Missing 'biblatex' package}
     {The bibliography requires the 'biblatex' package.}
      \aftergroup\endinput}
  {}
\endgroup


\refsection{0}
  \sortlist{entry}{nyt}
    \entry{zappone2009supermarketduopoly}{online}{}
      \name{labelname}{1}{}{%
        {{uniquename=0,hash=af62e8eb39454b026c19a85900defef2}{Zappone}{Z\bibinitperiod}{C.}{C\bibinitperiod}{}{}{}{}}%
      }
      \name{author}{1}{}{%
        {{uniquename=0,hash=af62e8eb39454b026c19a85900defef2}{Zappone}{Z\bibinitperiod}{C.}{C\bibinitperiod}{}{}{}{}}%
      }
      \strng{namehash}{af62e8eb39454b026c19a85900defef2}
      \strng{fullhash}{af62e8eb39454b026c19a85900defef2}
      \field{sortinit}{Z}
      \field{labelyear}{2009}
      \field{datelabelsource}{}
      \field{labeltitle}{Supermarket duopoly blamed for soaring food prices}
      \field{title}{Supermarket duopoly blamed for soaring food prices}
      \field{urlday}{03}
      \field{urlmonth}{29}
      \field{urlyear}{2014}
      \field{year}{2009}
      \verb{url}
      \verb http://www.smh.com.au/business/supermarket-duopoly-blamed-for-soaring-food-%20prices-20091109-i3tn.html
      \endverb
    \endentry
  \endsortlist
\endrefsection
\endinput

As you can see, it doesn't even contain the thebibliography environment...

As a side note, when using biblatex, it is recommended to use

\addbibresource{bibtest.bib}

instead of

\bibliography{bibtest}

The latter works for compatibility only.

share|improve this answer
    
Thank you Karl. When I run the my .tex file in TexWorks, I am running it with the options - pdflatex + MakeIndex + BibTex. However, no .bbl file is being created. The program runs without error, but the output after \parentcite{zappone2009supermarketduopoly} is just zappone2009supermarketduopoly. If I initially run BibTex first, it creates an empty .bbl file. –  Giri Mar 29 at 13:03
    
@Giri See this thread for configuring TeXWorks to run Biber: tex.stackexchange.com/q/69705/27635 –  karlkoeller Mar 29 at 16:38

You have to write \addbibresource{bibtest.bib} (with the .bib extension) instead of \bibliography{bibtest}(without the extension).

share|improve this answer
    
While \bibliography{filename} is generally deprecated in favour of \addbibresource{filename.bib}, the former does still work as advertised (if used correctly, but then, one also has to use \addbibresource properly). –  moewe Mar 29 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.