Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I found a template that uses the lettrine package with mathpazo. I want to use mathptmx, but when I use lettrine to make a large first letter, the second letter appears capitalized. The trick seems to be that the template uses the [sc] option for mathpazo, but I cannot find a comparable option for mathptmx. How can I have a large first letter with a lower-case second letter using mathptmx?

\documentclass[twoside]{article}    
\usepackage{mathptmx} 
% I get the expected behavior if I use \usepackage[sc]{mathpazo} instead
\usepackage{lettrine}

\begin{document}    
\section{Title}
\lettrine[nindent=0em,lines=3]{O} nce    
\end{document}
share|improve this question
    
Can you show a minimal working example (MWE)? –  egreg Mar 29 at 15:34
    
Thanks for posting a compilable example. You should write either \lettrine[nindent=0em,lines=3]{L}{orem} ipsum` or \lettrine[nindent=0em,lines=3]{L}{}orem ipsum. The former choice is more traditional, as it renders the remainder of the first word in small-caps (not all-caps). –  Mico Mar 29 at 15:41
    
@Mico Thanks, that solved it! You should write that up as an answer. –  Eric Mar 29 at 15:44
    
@Mico That solution will work but the package does actually provide the facility to change the default setting for the font of the remainder of the first word. This is explained in the documentation. I don't know if there are any cases in which the results will differ but I think it is a little clearer what is going on this way. See my answer. (Your comment wasn't here when I was writing that answer.) –  cfr Mar 29 at 15:54
    
@cfr - My guess is that the OP didn't know (or had forgotten) that the \lettrine command takes two mandatory arguments. Your solution, which redefines \LettrineTextFont, is certainly more elegant than inserting an empty group. –  Mico Mar 29 at 17:04

1 Answer 1

up vote 4 down vote accepted

By default, lettrine typesets the remainder of the first word, which is supposed to be the second mandatory argument to \lettrine, in small-caps. You can change this using

\renewcommand{\LettrineTextFont}{\upshape}

to get standard, upright lowercase instead. Note that this is happening with only the second letter of the first word in your case because you have not surrounded nce in curly brackets ({nce}).

Here's the corrected code with the command to get lower case in the preamble:

\documentclass[twoside]{article}
\usepackage{mathptmx}
% I get the expected behavior if I use \usepackage[sc]{mathpazo} instead
\usepackage{lettrine}
\renewcommand{\LettrineTextFont}{\upshape}
\begin{document}
\section{Title}
\lettrine[nindent=0em,lines=3]{O}{nce} upon a time, there was a little girl and a large dragon. They lived in a beautiful forest but the little girl was terrified of the large dragon and the large dragon was terrified of the little girl.
\end{document}

lettrine with lower case

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.