Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My friend and I are working on the same subject and I asked her to see her work. I noticed that her pdf rendering (if it's really that) is a lot different than mine even though we use the same "template". We both use TexMaker with MikTeX, hers is on Mac, mine is on Windows.

Left is mine, right is hers.

enter image description here

If anyone knows what cause the difference here and could help me getting the same thing that would be great.

Thank you.

share|improve this question
    
The difference is purely due to using different PDF viewers. –  ChrisS Apr 7 '14 at 7:44
1  
This question appears to be off-topic because it is about how the PDF is rendered in a PDF viewer, which is not a TeX problem. –  ChrisS Apr 7 '14 at 7:45
    
It's the same pdf viewer for both. –  AdrienNK Apr 7 '14 at 7:45
    
Macs default to 72 dpi whereas Windows defaults to 96 dpi; fitting the rather spindly CM fonts to different pixel grids will probably produce this difference. –  ChrisS Apr 7 '14 at 7:48
4  
It's quite improbable your friend uses MiKTeX on the Mac. More probable is that you (on MiKTeX) don't have the CMSuper fonts. Try adding \usepackage{lmodern} and see if the difference is still so striking. –  egreg Apr 7 '14 at 7:49

1 Answer 1

up vote 4 down vote accepted

MiKTeX doesn't run on Mac OS X, so probably your friend has installed MacTeX, which by default includes the CMSuper font package which provides Type1 renderings of the European Modern fonts that are used in documents that have

\usepackage[T1]{fontenc}

that's recommended when writing in French or another European language.

The fact is that the basic installation of MiKTeX doesn't include this font package (see Why are Bitmap-Fonts used automatically?). Install it with MiKTeX's package manager, otherwise the machine running MiKTeX will display bitmap fonts created at 600dpi, which is the most probable cause of the difference you see.

You can avoid this installation by adding to your document

\usepackage{lmodern}

that makes LaTeX use a different set of fonts that, however, are almost indistinguishable from the Computer/European Modern fonts. See Latin Modern vs cm-super? for more information.

Just to show what happens

Image with CMSuper fonts disabled

enter image description here

Image with CMSuper fonts enabled

enter image description here

Image with the Latin Modern fonts (\usepackage{lmodern})

enter image description here

share|improve this answer
    
all of which show (on my screen, at least) that a bitmap copy of a printed page isn't really a good reading medium. (admittedly the three do show differently. –  wasteofspace Apr 7 '14 at 9:42
    
@wasteofspace They don't render well on screen in PDF viewers. They should print fine, though. Metafont wasn't designed for this use... –  cfr Apr 7 '14 at 16:40
    
@cfr On that note, in you opinion what should be use for .pdf that will only be read on computers? –  AdrienNK Apr 8 '14 at 11:51
    
@AdrienNK You just need to make sure you are using type1, truetype or opentype fonts. This is recommended whether you want the PDF for printing or on-screen use. egreg's answer explains how to assure type1 fonts and this will work well for (pdf)LaTeX. –  cfr Apr 8 '14 at 12:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.