Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I seem to have a problem with margins. I'm using revtex4 (4-1 messes up my references, but that's not the point).

The preambule is this:

\documentclass[twocolumn,prc,floats,amsmath,amssymb]{revtex4}

And when I compile it I get this:

enter image description here

How to get the same amount of white space on the same sides?

Thanks for help :)

share|improve this question
    
You think it is a problem, but this is a class designed for a publication. They'll have done this quite deliberately: it is the binding offset so that after printing and binding everything looks okay. Normally, you should not mess with the layout of publication-ready classes. –  Joseph Wright May 1 '11 at 7:19
    
Yeah, but I used, for instance prc settings (physical review letter C) and it came this way, and my teaching assistant publishes in PRC and has nice and centered text... –  dingo_d May 1 '11 at 10:26

2 Answers 2

up vote 1 down vote accepted

You can use the centering option of the geometry package; this implies defining paperwidth, paperheight, and the margins. For a4paper you could use, for example, something like the following:

\usepackage[paperwidth=210mm,paperheight=297mm,centering,hmargin=2cm,vmargin=2.5cm]{geometry}

EDIT: I am not sure now what is what you want: if you want to have the same value for the right and left margins in all your document (i.e., to have the text centered in the page), then my previous suggestion will do the job. However, if you only want to keep the same values for the inner and outer margins in all the document, then you can simply add the twoside class option:

\documentclass[twoside,twocolumn,prc,floats,amsmath,amssymb]{revtex4}
share|improve this answer
    
The first one worked nicely, thanks ^^ –  dingo_d May 1 '11 at 10:24

I'm afraid i have to tell you that you seem to have another problem. revtex4 by default uses letterpaper format. Assuming you use a latex + dvipdf[m[x]] or latex + dvips toolchain it may be that the dvi converter crops to a4paper. That should also be notable throuth the very big bottom page margin (much space between page border and page number). You should use dvipdfmx -p letter to convert the dvi or add the a4paper option to your document class (which for some reasons does not work for me right now, that is the reason i stumbled over this question).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.