Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

enter image description here

Hi. I've compiled a Persian language beamer file by both luapersian and persian babel package using LuaLaTex, and in both I've the same problem in pdf bookmark as shown in the figure (some strange characters are shown instead of correct characters).

share|improve this question

closed as unclear what you're asking by Martin Schröder, Malipivo, Peter Jansson, Guido, Svend Tveskæg Apr 16 at 13:09

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Please add some code, which results in this image. As minimal as possible. We can't help you with such little information. –  LaRiFaRi Apr 15 at 8:43
    
Maybe \usepackage[pdfencoding=auto]{hyperref} does the trick. –  LaRiFaRi Apr 15 at 8:49
    
@Closers: It is not unclear, see my answer. –  Heiko Oberdiek Apr 16 at 12:18

1 Answer 1

Very likely you need option unicode for hyperref. It can be given the following way:

\documentclass[hyperref={unicode}]{beamer}

Alternatively (for other classes that load hyperref and do not have special options for specifying package options of loaded packages):

\PassOptionsToPackage{unicode}{hyperref}
\documentclass{beamer}
share|improve this answer
    
Thnx friend, works perfect. –  user49875 Apr 15 at 8:59
    
@Heiko Oberdiek: check this I posted yesterday, please: even if it looks like I can do without, I keep getting errors by assigning option unicode to package hyperref with several different syntaxes... –  MattAllegro Apr 15 at 10:01
1  
@MattAllegro: It's unrelated to option unicode. $ is a ASCII character with a special catcode that is not supported in bookmarks. With \texorpdfstring a different bookmark text can be supplied for stuff that is not supported there. –  Heiko Oberdiek Apr 15 at 12:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.