Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I´m using report (Koma script) and \pagenumbering{roman} and \pagenumbering{arabic} \setcounter{page}{1} in LaTeX code boxes where I need roman and arabic numbers respectively.

However, some pages randomly lack numbers. Some of them have pictures but others don't. What could be the reason? Any possible solution is well appreciated :)

share|improve this question
4  
We would need a minimal working example (MWE) in order to adequately address this problem. –  Werner Apr 16 at 2:18
1  
It looks there is \thispagestyle{empty} command in the process. Please edit your post and add fully compilable example. If you would like to refer to pictures, please use those included in the mwe package. –  Malipivo Apr 16 at 3:06
    
Sorry for not posting the MWE in my question. Here is the link: dropbox.com/sh/5za1s8aq0gor9u1/K3sXCifOPE @Malipivo –  Jouvett Garcia Apr 16 at 10:21

1 Answer 1

KOMA-Script uses page style empty for pages generated by \cleardoublepage since version 3.00 (see documentation, section "3.13. Interleaf Pages"). This can be changed by option cleardoublepage:

\KOMAoptions{cleardoublepage=plain}

Example:

\documentclass[twoside,openright]{scrreprt}
\KOMAoptions{cleardoublepage=plain}
\begin{document}
\tableofcontents
\chapter{Foo}
\chapter{Bar}
\end{document}
share|improve this answer
    
If I want a single side document, not twoside, how would the code be? Sorry if it´s a silly question, I´m new with Lyx. –  Jouvett Garcia Apr 16 at 10:34
    
Try to remove twoside, from the first line. –  Malipivo Apr 16 at 11:00
    
@JouvettGarcia: Without a MWE I had to speculate what might have caused the empty page style. With twoside \cleardoublepage can create empty pages, whose page style can be configured as shown above. –  Heiko Oberdiek Apr 16 at 11:35
    
Sorry for not posting the MWE in my question. Here is the link: dropbox.com/sh/5za1s8aq0gor9u1/K3sXCifOPE @HeikoOberdiek –  Jouvett Garcia Apr 16 at 14:38
    
@JouvettGarcia: I don't have/use Lyx. –  Heiko Oberdiek Apr 16 at 16:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.