Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I need to create an index in my document, so I put the following lines in my preambel

\usepackage{makeidx}
\usepackage{showidx}
\makeindex

So, when compiling with TeXnicCenter, I noticed the following line in the log

Can't create output index file E:\...\doc.ind

No further information on why - just this line. Of course, in the compiled document, there is no index (duh!) - So, why does this error ocurr and how can I get TeXnicCenter to produce the index file?

If I run makeindex myself over cmd, it runs smoothly and creates the index without a problem.

share|improve this question

1 Answer 1

up vote 14 down vote accepted

In current versions of the common TeX distributions (MiKTeX 2.9, TeX Live 2010) MakeIndex as well as BibTeX have got a security mechanism that prevents them from processing files with absolute paths. Therefore you have to modify the settings in TeXnicCenter (TXC) as shown in the picture. Replace "%bm" with "%tm" wherever you can find it in your build profiles.


enter image description here

share|improve this answer
1  
Wow, how do you figure out something like this? That's the last thing I would've checked... Still, a problem remains: When I index something using \index{word}, and I \printindex it, the entry is indexfile, 7 instead of word, 7 –  Florian Peschka May 3 '11 at 6:49
1  
Such things get about. Perhaps this special issue can be found in the manual of the concerned TeX distribution. I can't remember where I got it from. Regarding your problem you are better with closing this question and opening a new one to receive detailed answers. –  Thorsten Donig May 3 '11 at 7:52
1  
same here ... I'm glad I stumbled over this entry more or less by chance. All's well after changing %bm to %tm though I don't understand why :-) –  user5860 May 31 '11 at 14:15
    
@Nicholas Lack: Instead of posting a “Thank you” as an additional answer, you should thank Thorsten by upvoting his answer (with the upward pointing arrow to the left of it). We want to keep the answer space reserved for actual answers, so I converted your non-answer to a comment. You can't add comments to other posts as long you don't have 50 reputation. –  Martin Scharrer May 31 '11 at 14:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.