Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

citations.bib contains:

@Book{hicks2001,
 author    = "von Hicks, III, Michael",
 title     = "Design of a Carbon Fiber Composite Grid Structure for the GLAST
              Spacecraft Using a Novel Manufacturing Technique",
 publisher = "Stanford Press",
 year      =  2001,
 address   = "Palo Alto",
 edition   = "1st",
 isbn      = "0-69-697269-4"
}

The tex file:

\documentclass[a4paper, 11pt, notitlepage]{report}
\usepackage[backend=bibtex]{biblatex}
\addbibresource{citations.bib}
\begin{document}

\nocite{*}
\printbibliography 

\end{document}

This command will not print the bibliography, although there is no compiling error. What's the problem? I'm using TeXstudio in Windows 8.1. I have tried using XeLatex + Biber, PdfLatex + Biber, PdfLatex + BibTeX.

Update: Now, I included

\usepackage[backend=bibtex]{biblatex}

and I got error:

No file untitled.bbl
share|improve this question
    
Isn't your problem causing the year? 2001 -> "2001" –  Malipivo Apr 21 at 7:57
    
Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. –  Christian Hupfer Apr 21 at 8:02
2  
I have no problem compiling it. Are the .bib file and the .tex file in the same directory? –  Bernard Apr 21 at 8:21
    
Yes, it is in the same directory. –  user74158 Apr 21 at 8:29
    
can you run biber from the command line? –  Guido Apr 21 at 9:20

1 Answer 1

Judging from some of the information provided among the comments, it may be the case that you (i) can't invoke biber from within TeXstudio and (ii) don't know how to open a command window to run biber "by hand". I take it you do know how to execute bibtex from within TeXstudio.

If that's the case, and if your bibliographic entries don't contain any special, i.e., non-7bit-ASCII characters that will create problems under BibTeX, you could proceed by specifying the option backend=bibtex when loading the biblatex package. Then, as usual, run latex, bibtex, and latex twice more to get all references and all citation callouts fully updated.

enter image description here

\documentclass[a4paper, 11pt, notitlepage]{report}
\usepackage{filecontents}  % create "citations.bib" on-the-fly
\begin{filecontents*}{citations.bib}
@Book{hicks2001,
   author    = "von Hicks, III, Michael",
   title     = "Design of a Carbon Fiber Composite Grid Structure for the 
                GLAST Spacecraft Using a Novel Manufacturing Technique",
   publisher = "Stanford Press",
   year      =  2001,
   address   = "Palo Alto",
   edition   = "1st",
   isbn      = "0-69-697269-4"
}
\end{filecontents*}
\usepackage[backend=bibtex,style=numeric]{biblatex}
\addbibresource{citations.bib}
\begin{document}
\nocite{*}
\printbibliography 
\end{document}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.