Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
  \documentclass[11pt,table,a5paper]{article}
  \usepackage[top=2cm, bottom=2cm, outer=2.1cm, inner=1cm,twoside, headsep=26pt]{geometry}
  \usepackage{collcell}
  \begin{document}
      20 µg/mL
  \end{document}

In the above example mu is not visible. How can i fix this error?

share|improve this question
6  
\usepackage{siunitx} and then \SI{20}{\micro\gram\per\milli\liter} –  egreg Apr 21 at 9:30
    
\usepackage{fontspec} and compile with xelatex or lualatex. –  morbusg Apr 21 at 11:55

3 Answers 3

If you want to use Greek characters in text mode more often, you could consider loading the package textgreek. This is shown in my first version.

The second version is much more elegant and uses the package siunitx. I think, you should get used to this package, as it does a lot of nice work for you.

% arara: pdflatex

\documentclass{article}
\usepackage{textgreek}
\usepackage[per-mode=symbol-or-fraction]{siunitx} % for super easy handling of such cases.


  \begin{document}
With textgreek, it looks like 20 \textmu{}g/mL. 

You could also use the package siunitx and write \SI{20}{\micro\gram\per\milli\litre}
  \end{document}

enter image description here

siunitx gives a nicer fitting µ, a nicer (narrow) spacing, corrects your big L to a small l and gives you the possibility to change to a µg ml^-1 version or other things later on.

share|improve this answer

If an input encoding (package inputenc) is not specified, then TeX maps the characters to the output font encoding directly, which is OT1 by default. OT1 is restricted to 7-bit. The question does not say, in which encoding the TeX input file is written, but µ is mapped to 8-bit character(s) in most encodings (e.g., UTF-8, Latin 1, CP 1252). Then TeX will lost that character, because the font encoding OT1 does not provide a slot for it.

TeX can report the lost characters:

\tracinglostchars=2

Result for 8-bit encoding:

Missing character: There is no µ in font cmr10!

Result for UTF-8 (multi-byte):

Missing character: There is no � in font cmr10!
Missing character: There is no � in font cmr10!

Solution:

  • Package inputenc makes the 8-bit characters active to support them independently from the font encoding. µ is usually mapped to \textmu.

  • Package textcomp uses the upright µ from font encoding TS1. Default font family is the EC fonts, an extension to the CM fonts for font encodings T1 and TS1.

\documentclass[11pt]{article}
\usepackage[utf8]{inputenc}
\usepackage{textcomp}
\begin{document}
  20 µg/mL
\end{document}

Result

Further hints:

  • Recommended package for units: siunitx. Using logical markup makes it easier to change the appearances of the units (with numbers) via the many configuration options of siunitx.

  • Package fontspec with Unicode fonts that include µ is recommended for users of LuaLaTeX/XeLaTeX.

share|improve this answer

What if you use $\mu$, as long as you need a single character?

I would further advice to you to define a new command to denote micrograms per milliliter (??), such as

\newcommand{\unit}{\ensuremath{\mu}g/mL}

(if you denote liters with capital L).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.