Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In my table of contents, some of the dot fills do not end at the same place as the other lines. What is causing this and how can I make the dot fills uniform? A red oval highlights the problem in the following screenshot:

Extra dot in ToC

Edit: It looks as if the page number "101" is slightly less wide than the other page numbers, allowing just enough room for an extra dot. This is probably the cause, but I still don't know how to fix the problem.

Edit 2: Minimal working example below. The document class is located at https://github.com/wannesm/adsphd/blob/master/adsphd.cls, and is quite long -- apologies for the inconvenience.

\documentclass{adsphd}

\begin{document}

\mainmatter % Arabic page numbering

\tableofcontents

\setcounter{page}{98}
\chapter{Numerical solution of bivariate and polyanalytic polynomial systems}
\section{Introduction}\clearpage
\section{Notation and preliminaries}\clearpage
\section{Solving systems of bivariate and polyanalytic polynomials}\clearpage
\subsection{The polynomial eigenvalue problem}\clearpage
\subsection{Balancing the system and its associated pencil}\clearpage
\subsubsection{Balancing the bivariate system}\clearpage
\subsubsection{Balancing the polyanalytic system}\clearpage
\subsubsection{Balancing the pencil}\clearpage
\section{Numerical experiments}\clearpage
\section{Conclusion}\cleardoublepage

\end{document}
share|improve this question
2  
Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. –  Christian Hupfer Apr 22 at 9:19
    
In my point of view, there is a large gap at the end of preliminaries and the beginning of the dotted line. On a second look on your image, this is true however for 5.3.1 and 5.5 also :-( –  Christian Hupfer Apr 22 at 9:27
1  
Your edit does not improve the situation for possible helpers. As @ChristianHupfer suggested, add the code that yelds this output (or some minimal working example showcasing the undesired behaviour). As far as I know, there aren't any fortunetellers on TeX.SX... –  Ruben Apr 22 at 9:27
    
Indeed. I suggest you make a copy of your document where you remove all text but keep the headers (but not past this chapter). Do you still get this anomaly in the table of contents? Then remove stuff from your preamble that you need only for that text that is removed anyway. Check if there is still a problem. If there is, you have something to post that will help us help you. –  pst Apr 22 at 9:33
    
I am lost sure I saw a similar (identical) question here... –  Dror Apr 22 at 9:44

1 Answer 1

up vote 4 down vote accepted

This is a problem with microtype. Use

\microtypesetup{protrusion=false}
\tableofcontents
\microtypesetup{protrusion=true}

for the Table of Contents.

share|improve this answer
    
Yes, you are right. If one removes \usepackage{microtype} from that class file, the error vanishes also! Perhaps, one should notify the maintainer/creator of the class file about this 'feature'? –  Christian Hupfer Apr 22 at 10:03
    
Great, thanks a lot! Is this a bug in microtype that will be fixed soon? –  Starlyght Apr 22 at 10:08
2  
It is mentioned in the microtype documentation in the "Hints and caveats" chapter as one of the places where you might want to disable protrusion. I'm not sure it can be seen as a bug in microtype as such. Rather I think that classes that use it ought to redefine \tableofcontents like this. –  pst Apr 22 at 10:13
1  
@ChristianHupfer I've notified the maintainer of the class, should be fixed soon - thanks! –  Starlyght Apr 22 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.