Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My question has been asked before but none of the answers previously has answered my question. I have an .eps file that I want to include in my LaTeX document. For this purpose I have included the epstopdf package. However, when I try to compile my document by using pdflatex, I get the error message File 'foo-eps-converted-to-pdf' not found. In the log file it says:

{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] [2]
Package epstopdf Info: Source file: <Aoo.eps>
(epstopdf)                    date: 2014-04-28 18:54:16
(epstopdf)                    size: 18858 bytes
(epstopdf)             Output file: <foo-eps-converted-to.pdf>
(epstopdf)             Command: <epstopdf --outfile=foo-eps-converted-to.pdf foo.eps>
(epstopdf)             \includegraphics on input line 142.
runsystem(epstopdf --outfile=foo-eps-converted-to.pdf foo.eps)...disabled.

Package epstopdf Info: Result file: <foo-eps-converted-to.pdf>.

! Package pdftex.def Error: File `foo-eps-converted-to.pdf' not found.

See the pdftex.def package documentation for explanation. Type  H
<return>  for immediate help.  
...                                    

l.142 \includegraphics{foo.eps}

It should be noted that all files are in the same directory, so there shouldn't be any issues with that.

Any suggestions? Thanks in advance!

share|improve this question

2 Answers 2

up vote 3 down vote accepted

The important line of the .log file is:

runsystem(epstopdf --outfile=foo-eps-converted-to.pdf foo.eps)...disabled.

The conversion do not work, because the shell escape feature is not enabled. Probably you are using an older TeX distribution. TeX Live and MiKTeX have a the restricted shell escape feature enabled by default.

On older systems (not too old, of course) the following option should work:

pdflatex --shell-escape

or (MiKTeX)

pdflatex --enable-write18
share|improve this answer
    
Thanks for your suggestion! I tried it, but unfortunately it didn't work. I also got the same line that you quoted in the log file. My TeX system is probably not too old; I downloaded it in 2012. –  user50733 Apr 28 '14 at 21:01
    
Which TeX distribution and version do you use? Any message on the console about unrecognized option '-shell-escape'? –  Heiko Oberdiek Apr 28 '14 at 21:28
    
It worked now! I was stupid enough to write "pdflatex filename --shell-escape" rather than "pdflatex --shell-escape filename" the first time. What does, in fact, "-shell-escape" do? –  user50733 Apr 28 '14 at 21:31
    
To answer your question, I use TeX Live 2009 for Debian. –  user50733 Apr 28 '14 at 21:36
    
-shell-escape allows the execution of external programs. In this case the program epstopdf converts the EPS file to PDF, which is then included. –  Heiko Oberdiek Apr 28 '14 at 21:50

Just in case somebody else stumbles upon the same error message. In my case the issue emerged from the file path of the *.eps file referenced in the *.eps_tex file, since I had all my pics in a separate subfolder called pics.

Changing

\put(0,0){\includegraphics[width=\unitlength]{foo.eps}}

in the foo.eps_tex file to

\put(0,0){\includegraphics[width=\unitlength]{pics/foo.eps}}

solved the problem.

Maybe this helps somebody.

share|improve this answer
    
Welcome to TeX.SX! –  Andrew Swann May 27 at 11:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.