Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In the following snippet code of a beamer presentation, in the slide 3/8 there is a strange space that appears as shown in the picture. please I need to get rid of it, how to do that ?

enter image description here

\documentclass[11pt,a4paper]{beamer}

\usepackage[applemac]{inputenc}
\usepackage[frenchb]{babel}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{lmodern}

\title{Unité 5 - Techniques d'exploration du web }
\author{ALJI Mohamed}
\institute{Faculté de lettre - Université Ibn Tofail}
\date{\today}

\usetheme{CambridgeUS}

\AtBeginSection[]{
  \begin{frame}
   \frametitle{Plan}
   \tableofcontents[currentsection, currentsubsection]
  \end{frame} 
}

\AtBeginSubsection[]{
  \begin{frame}
   \frametitle{Plan}
   \tableofcontents[currentsection, currentsubsection]
  \end{frame} 
}

\AtBeginSubsubsection[]{
  \begin{frame}
   \frametitle{Plan}
   \tableofcontents[currentsubsection, currentsubsubsection]
  \end{frame} 
}

\setbeamertemplate{footline}{\hspace{28em}\insertframenumber/\inserttotalframenumber\vspace{1em}\null}

\beamertemplatenavigationsymbolsempty

\begin{document}

% slide Titre %
\begin{frame}
\titlepage
\end{frame} 

% slide Plan %
\begin{frame}
   \frametitle{Plan}
 \tableofcontents[]
\end{frame}

% -------------- Debut ------------- % 
 
\section{Histoire d'internet}
\begin{frame} 
\frametitle{Histoire d'internet}

\end{frame}

% ---------------------------------- %
\section{Services d'internet}
\subsection{sub section 1}

% ---------------------------------- %
\section{Les outils de recherche}

% ---------------------------------- %
\section{Les techniques de recherche}

% ----------------- Fin ------------%
\begin{frame} 
\frametitle{}
frame 2
\end{frame}

\end{document}

Here is another MWE smaller that produce the same error !

\documentclass[11pt,a4paper]{beamer}

\usepackage[applemac]{inputenc}
\usepackage[frenchb]{babel}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{lmodern}

\title{Reconnaissance des Tumeurs Cérébrales\\ État de l'Art}
\author{M. ALJI Mohamed}
\institute{LaRIT - Faculté des Sciences - Université Ibn Tofail Kénitra}
\date{$1^{ere}$ Journée Scientifique en Informatique et Mathématiques\\
29 Mai 2014, Mehdia,Kenitra}

\usetheme{CambridgeUS}

\setbeamertemplate{footline}{\hspace{28em}\insertframenumber/\inserttotalframenumber\vspace{1em}\null}

\beamertemplatenavigationsymbolsempty

\begin{document}

% slide Titre %
\begin{frame}
\titlepage
\end{frame} 

% slide Plan %
\begin{frame}
   \frametitle{Plan}
 \tableofcontents[]
\end{frame}

% -------------- Debut ------------- % 
 
\section{Introduction}
\begin{frame} 
\frametitle{Introduction}
ssss

\end{frame}
\end{document}

I am using Mac OS X Snow Leopard 10.6.8 with TeXShop Version 2.47 from MacTeX, and TeX Live 2013.

I even can't reproduce the problem all time ! but I need an explanation.

Thank you

share|improve this question

closed as unclear what you're asking by Joseph Wright Apr 11 at 21:54

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

    
Your MWE doesn't compile because subsections option in \tableofcontents[currentsection, subsections] breaks it. By the way, hyperref is already loaded by beamer which also loads xcolor (no need for color). Please provide a valid MWE. –  Ignasi Apr 30 '14 at 7:31
    
I don't know what is it MWE ?? So in the snippet, I can remove \usepackage{color} ?? and remove \usepackage{hyperref} with no problem ? –  Ojiryx May 16 '14 at 16:16
3  
I have tried both of your MWEs but cannot reproduce the problem. What OS / LaTeX-Distro / Editor are you using? –  Ulmo May 28 '14 at 9:21
1  
A LaTeX distro is for example TeX Live (en.wikipedia.org/wiki/TeX_Live). As it seems that other people can not reproduce this, it would appear that it is a problem in your setup. Make sure you have the most recent and unmodified versions of LaTeX and other components installed. Sometimes it helps even just to delete all temporary files and recompile. –  Ulmo May 28 '14 at 15:21
2  
I can also not reproduce the problem, but when using your first MWE I get 9 pages in total, whereas your picture looks like you get 8 pages? Is that correct? –  samcarter May 28 '14 at 15:24

Browse other questions tagged or ask your own question.