Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've been trying to add the --shell-escape argument to my pdflatex, and right about nothing works. I'll summarize what I've done so far:

  1. Add --shell-escape to existing pdflatex.exe
  2. Add --shell-escape to \texlive\2013\bin\win32\pdflatex.exe
  3. The console either gets stuck at "ABD: EveryShipout initializing macrosgnuplot not recognized", or
  4. "Package gnuplottex Warning: Shell escape not enabled. (gnuplottex) You'll need to convert the graphs yourself..", or
  5. TeXworks produces no PDF
  6. I have also tried running different compilers such as miktex-pdftex.exe, pdftex.exe, etc.
  7. I'm running the latest MikTeX / TeX distributions, packages, etc. (just updated everything in my TeX Live Manager)

This only seems to be a big deal when I run anything GNUplot related.

What's going on here?

ScreenshotOfArgumentsPdflatex

share|improve this question

1 Answer 1

up vote 5 down vote accepted

To long for a comment. Run this document with --shell-escape:

\documentclass{article}
\begin{document}
\immediate\write18{echo "hallo"}
blub
\end{document}

Then check the log file. If you found thererunsystem(echo "hallo")...disabled (restricted) then --shell-escape has not been activated. If the message is runsystem(echo "hallo")...executed. then everything works and your problem lies somewhere else.

share|improve this answer
    
runsystem(echo "hallo")...executed.... However, when I try to GNUplot, it tells me: Package gnuplottex Warning: Shell escape not enabled. (gnuplottex) You'll need to convert the graphs yourself.. While within the log file itself it also shows: runsystem(rm -f w18-test-2014430619.tex)...executed. I'm assuming this line also means that --shell-escape works as intended? @Ulrike Fischer –  1010011010 Apr 30 at 8:17
    
At least you now know that you have been looking at the wrong places for a solution. Did you load the package with the miktex option \usepackage[miktex]{gnuplottex}? –  Ulrike Fischer Apr 30 at 8:25
    
Yes @Ulrike Fischer –  1010011010 Apr 30 at 10:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.