Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using Pandoc to convert Markdown to LaTeX. A subset of the output looks like this:

\documentclass[bachelor]{stpthesis}
\usepackage{booktabs,longtable}
\begin{document}
\begin{longtable}[c]{@{}lcll@{}}
\toprule\addlinespace
& f1 & precision & recall
\\\addlinespace
\midrule\endhead
None & 0.421022 & 0.507951 & 0.503386
\\\addlinespace
PPMI & 0.603329 & 0.637012 & 0.617783
\\\addlinespace
PLOG & 0.490976 & 0.622938 & 0.558508
\\\addlinespace
EPMI & \textbf{0.674587} & 0.675957 & 0.674943
\\\addlinespace
PLMI & 0.43577 & 0.512759 & 0.506313
\\\addlinespace
\bottomrule
\end{longtable}
\end{document}

Which gives the following result: PDF output

As you can see in the LaTeX markup, the EPMI f1 score is supposed to be bolded, yet it doesn't turn up that way in the PDF output. Any idea why that is? The log file gives no indication of warnings considering the table formatting.

Thanks!

EDIT: I have realized that the problem seems to lie in the custom document class we are using. If you feel like looking further into it, you may take a look at the document class here.

share|improve this question
    
Works fine here, can you create a complete example showing the problem? –  Torbjørn T. May 1 at 15:04
    
Did you remember to compile the program twice? –  Mico May 1 at 15:08
    
@Mico Shouldn't make a difference for \textbf, should it? –  Torbjørn T. May 1 at 15:10
1  
@JimmyC Unless you can give a link to the source of the class, then it would be quite difficult for us to help you, yes. –  Torbjørn T. May 1 at 15:13
3  
@Mico I got boldface immediately. –  egreg May 1 at 15:26

1 Answer 1

up vote 8 down vote accepted

By default the class stpthesis loads package uufonts:

\NeedsTeXFormat{LaTeX2e}
\ProvidesPackage{uufonts}[2007/02/08 v1.2 UU fonts]
\RequirePackage[T1]{fontenc}
\RequirePackage{textcomp}
\renewcommand*{\rmdefault}{pbr}
\renewcommand*{\sfdefault}{mgs}
% No official recommendation from UU, but this seems to suit rather well.
\renewcommand*{\ttdefault}{lmtt}
% No official recommendation, but eulervm is cool since it uses one's
% standard font for digits etc.
\usepackage[small]{eulervm}
\endinput

exempel.log contains the warning:

LaTeX Font Warning: Font shape `T1/pbr/m/n' undefined
(Font)              using `T1/cmr/m/n' instead on input line 11143.

Therefore I conclude that you have not installed the fonts of families pbr and mgs, needed for package uuthesis.

The fonts are not in TeX Live, thus you have asked, where you have got the class.

As workaround you can try class options cm or times, because they are using different fonts that are probably installed (guessing from the names).

share|improve this answer
    
You were absolutely correct, thank you! –  Jimmy C May 1 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.