Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the appropriate keystrokes to get curly quotes, but I'm not getting them. What is wrong here?

\documentclass[nols,nohyper,openany, letterpaper]{tufte-book}



\definecolor{Ahrenge}{RGB}{214, 88, 18}
\usepackage{fontspec}
\setmainfont{Georgia}
\setsansfont{Georgia}
\usepackage{lipsum}
%\usepackage{biblatex}
\usepackage{hyperref}
\hypersetup{colorlinks,linktocpage,urlcolor=Ahrenge}




\begin{document}

%\maketitle

%\pagestyle{mystyle}
\chapter{Notes}



\bigskip

\section{Please help}

Here is a ``quote,'' but it is ``quite fake.''

\end{document}
share|improve this question

1 Answer 1

You just need to tell XeLaTeX that you wish to use standard TeX ligatures:

\documentclass[nols,nohyper,openany, letterpaper]{tufte-book}



\definecolor{Ahrenge}{RGB}{214, 88, 18}
\usepackage{fontspec}
\setmainfont[Mapping=tex-text]{Georgia}
\setsansfont[Mapping=tex-text]{Georgia}
\usepackage{lipsum}
%\usepackage{biblatex}
\usepackage{hyperref}
\hypersetup{colorlinks,linktocpage,urlcolor=Ahrenge}




\begin{document}

%\maketitle

%\pagestyle{mystyle}
\chapter{Notes}



\bigskip

\section{Please help}

Here is a ``quote,'' but it is ``quite fake.''

\end{document}

XeLaTeX

If you are using LuaTeX rather than XeTeX:

\documentclass[nols,nohyper,openany, letterpaper]{tufte-book}



\definecolor{Ahrenge}{RGB}{214, 88, 18}
\usepackage{fontspec}
\setmainfont[Ligatures=TeX]{Georgia}
\setsansfont[Ligatures=TeX]{Georgia}
\usepackage{lipsum}
%\usepackage{biblatex}
\usepackage{hyperref}
\hypersetup{colorlinks,linktocpage,urlcolor=Ahrenge}




\begin{document}

%\maketitle

%\pagestyle{mystyle}
\chapter{Notes}



\bigskip

\section{Please help}

Here is a ``quote,'' but it is ``quite fake.''

\end{document}

LuaLaTeX

As the manual explains, this second syntax will also work for XeLaTeX because fontspec will translate it into the Mapping=tex-text invocation. See fontspec's documentation for further details and other options.

share|improve this answer
2  
In fact, the documentation prefers Ligatures=TeX in both engines. –  Manuel May 3 at 1:16
    
The bit I looked up said that Ligatures=TeX would be turned into Mapping=... in the case of XeLaTeX but that Mapping=... was really the mechanism involved. If anything, it implied that the mapping one to the other was there just so things more-or-less worked as expected when people used the 'wrong' configuration setting. [Note: I'm not saying this is correct - just that's what the fontspec manual indicated.] –  cfr May 3 at 1:20
    
You are right, but there's nothing wrong with only using Ligatures, that's all. A quote from the manual: “Using the tex-text mapping is also equivalent to writing Ligatures=TeX. The use of the latter syntax is recommended for better compatibility with LuaTEX documents.” –  Manuel May 3 at 1:29
    
@Manuel Fair enough. –  cfr May 3 at 2:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.