Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have acquired an otf font (Aphrodite Pro) to print some wedding invitations; don't be alarmed, it is quite swashy as it is. But, what i get using the default variant are the contextuals of that font on all positions in a word. It is also the variant I see, when I type stuff in Libre Office writer. Going through the variants doesn't change anything. This problem is not really xelatex related, though my invitations are written in xelatex.

You can have a look at the font here: Aphrodite Pro

Font Forge: when looking at the otf file using FontForge I see that the character I get when I type 'r' is not the one deposited at U+0072 but one that is located at the bottom of the FontForge page without a unicode number, it is labelled as "r_bye" and has a hex code of 0x1004c.

So my question: How can I make the font bahave and display sensible characters? (Maybe I use the words "font variant" incorrectly, because i see the contextuals and not a variant)

An example:

 \documentclass[a6paper,pagesize]{scrartcl}
 \usepackage{fontspec}
 \usepackage{microtype}
 \usepackage{polyglossia}
 \usepackage{graphicx}
 \usepackage{amsmath}
 \usepackage[usenames]{xcolor}
 %\addtokomafont{section}{\rmfamily}

 \setmainfont{Aphrodite Pro}
 %\setmainfont{Linux Libertine O}

 \setdefaultlanguage{german}

 \begin{document}
 \pagestyle{empty}
 \vspace*{-3cm}
 \hspace*{-3cm}{\color{gray}\fontsize{140}{1em}\selectfont\&}
 \vspace*{-1cm}

 \section*{Dear \$\{person\}}

 Text abcdefg RRRR rrrr

 \end{document}

What I get is: Result converted from pdf

share|improve this question
    
Welcome to TeX.SX! –  Heiko Oberdiek May 5 at 13:02
    
It's not possible to answer the question of how to make the font "behave" and produce "sensible" characters, since that's a subjective opinion. However, my guess is that the input character r is substituted with r_bye by some OpenType feature. It's not possible, however, to say what feature that is without looking at the font. Browse through the Lookups tables in FontForge, and you'll probably find the substitution there. –  Sverre May 5 at 13:05
1  
Well, i don't fully agree, because this is not how the font looks when i try it out on myfonts, where i bought it. Putting weird swashes everywhere is objectively wrong, when i leave all settings in default. I expect to see the "Text" variant but I get the "Contextuals" variant. That is not a matter of opinion (this sentence is though). –  user51141 May 5 at 13:33
    
I don’t have that font, but it sounds as if you need to use \setmainfont[Contextuals=NoAlternate]{Aphrodite Pro} (the calt feature is on by default in xetex, which is appropriate for most well behaved fonts). –  Thérèse May 5 at 16:39
    
Yes! Thank you so much. I have tried all but the one you mentioned. NoWordInitial and so forth didn't seem to work. –  user51141 May 6 at 12:19

1 Answer 1

As Thérèse pointed out, the wild swashes went away by setting

\setmainfont[Contextuals=NoAlternate]{Aphrodite Pro}

Chapeau!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.