Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

I have issues with setting up citations in the text itself and creating a reference list. I used jabref to create citations and I saved the bib-data as Literatur.bib in the folder in which I have all other files. Shortended Code:

\documentclass[12pt]{article}

\usepackage[backend=biber,style=apa,babel=other]{biblatex}
\usepackage[babel,german=quotes]{csquotes}
\usepackage[locale=US]{siunitx}

\DeclareLanguageMapping{ngerman}{ngerman-apa}

\addbibresource{Literatur.bib}

\begin{document}
This is supposed to be a quote here \cite{Example2000}.
\newpage
\printbibliography 
\end{document}

In text, the citation appears as Example2000 in bold letterings, not as supposed in (Example, 2000). A reference list is not set up.

Warnings:

'babel' option is deprecated, use 'autolang' instead. Citation 'Example2000' on page 4 undefined Empty bibliography There were undefined references. Please (re)run Biber on the file:(biblatex) Abschlussbericht(biblatex) and rerun LaTeX afterwards.

In the bib-data, the reference looks like:

@Article{Example2000,
  Title                    = {Test},
  Author                   = {Example, V.},
  Journal                  = {Example magazine},
  Year                     = {2000},
  Pages                    = {33-37},
  Volume                   = {8},
}

What am I doing wrong? :(

share|improve this question

marked as duplicate by moewe, Masroor, Malipivo, Andrew Swann, Christian Hupfer May 9 at 7:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3  
Did you run pdflatex, biber, pdflatex? –  musicman May 6 at 14:18
    
Yes, did not work –  Jens May 8 at 23:30
    
Possible duplicate of Biblatex with Biber: Configuring my editor to avoid undefined citations. (As per a comment by the user posted as an answer that has been removed since.) The clue is in the error message Please (re)run Biber on the file .... –  moewe May 9 at 5:11

1 Answer 1

up vote 1 down vote accepted

Your problem is how you define your used languages. Looks like you're using depracted code. You didn't load the babel-package for example. Look at your updated MWE. Now it should work:

\documentclass[12pt,ngerman]{article}%mod.

\usepackage[ngerman]{babel}%added
\usepackage[backend=biber,style=apa]{biblatex}%mod.
\usepackage[german=quotes]{csquotes}%mod.
\usepackage[locale=US]{siunitx}

\DeclareLanguageMapping{ngerman}{ngerman-apa}

\usepackage{filecontents}%include your bib-file for testing purposes
\begin{filecontents}{Literatur.bib}
@Article{Example2000,
  Title                    = {Test},
  Author                   = {Example, V.},
  Journal                  = {Example magazine},
  Year                     = {2000},
  Pages                    = {33-37},
  Volume                   = {8},
}
\end{filecontents}
\addbibresource{Literatur.bib}

\begin{document}
This is supposed to be a quote here \cite{Example2000}.
% \newpage
\printbibliography 
\end{document}
share|improve this answer
    
If this answer solves your problem, please mark it as accepted answer and maybe upvote it. This is what keeps the board alive :) –  musicman May 7 at 6:18
    
In my case, I did not inbound biber.exe in TeXStudio. That's why it did not work. To do this: options --> configure TeXStudio --> commands --> link biber.exe in the section "biber" –  Jens May 10 at 18:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.