Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use this class definition in the preamble for typesetting letters:

\documentclass[12pt,ngerman,foldmarks=true,fromalign=right,fromrule=afteraddress,
  parskip=half, pagenumber=no,DIV=15]{scrlttr2}

%\usepackage[a4paper]{geometry}
%\geometry{verbose,tmargin=2cm,bmargin=0cm,lmargin=2cm,rmargin=2cm}

I have to struggle with the general problem that latex compiles into a letter with 2 pages. On the first page the last third is just empty. On the second page there is only the closing preceded by the last line of the last paragraph. It's ugly and wastes a lot of paper.

I mean, there is no point in only printing the signature on a new page.

Do you have the same problem and how do I get around that?

share|improve this question

2 Answers 2

up vote 12 down vote accepted

With scrlttr2 I sometimes used \enlargethispage as a quick way to get more text onto the first page, for example:

\enlargethispage{3\baselineskip}

Done before the end of the letter or before the end of the first page, respectively, this allows three further lines on the page. There's even a starred version \enlargethispage* which tries also compression.

Alternatively, you could use the option enlargefirstpage=true which increases the text area if the footer of the first page doesn't use much space, or adjust the pseudolength firstfootvpos or use typearea package features. I quickly took the easy first way, depending on my letter's size. The other ways are described in the KOMA-Script manual.

share|improve this answer
    
I had read about \enlargethispage, enlargefirstpage=true and firstfootvpos beforehand. I was not sure which one would be the 'cleanest' way to achieve my goal. "enlargefirstpage=true" and "\enlargethispage{3\baselineskip}" each seem to do the job in my case. Thanks! –  user2159 May 6 '11 at 20:23

Combination of option enlargefirstpage and firstfoot=false is a very easy solution to enlarge first page:

\documentclass[12pt,fromalign=right,fromrule=afteraddress,
               parskip=half,pagenumber=no,DIV=15,
               enlargefirstpage,firstfoot=false]{scrlttr2}

I've removed option foldmarks=true, because it's default. All other options are unchanged from question.

share|improve this answer
    
These options do not work. I explicitly get errors when using firstfoot=yes –  cryptic0 Apr 14 '13 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.