Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Today I updated MikTeX and the process aborted. After that, the program does not show the list of packages in the update (admin) program. I changed the package repository address and the program informs the following error:


Error report:

MiKTeX Problem Report
Message: Unknown package.
Data: uni-wtal-ger
Source: Libraries\MiKTeX\PackageManager\PackageManager.cpp
Line: 1026
MiKTeX: 2.9
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
Invokers: explorer
SystemAdmin: yes
PowerUser: no
Root0: C:\Documents and Settings\Administrador\Datos de programa\MiKTeX\2.9
Root1: C:\Documents and Settings\Administrador\Configuración local\Datos de programa\MiKTeX\2.9
Root2: C:\Documents and Settings\All Users\Datos de programa\MiKTeX\2.9
Root3: C:\Archivos de programa\MiKTeX 2.9
UserInstall: C:\Documents and Settings\Administrador\Datos de programa\MiKTeX\2.9
UserConfig: C:\Documents and Settings\Administrador\Datos de programa\MiKTeX\2.9
UserData: C:\Documents and Settings\Administrador\Configuración local\Datos de programa\MiKTeX\2.9
CommonInstall: C:\Archivos de programa\MiKTeX 2.9
CommonConfig: C:\Documents and Settings\All Users\Datos de programa\MiKTeX\2.9
CommonData: C:\Documents and Settings\All Users\Datos de programa\MiKTeX\2.9

After that, the list of packages is empty.

I searched the uni-wtal-ger package and found it in C:\Archivos de programa\MiKTeX 2.9\tpm\packages. This file has the following content:


<?xml version="1.0" encoding="iso-8859-1"?>
<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:TPM="http://texlive.dante.de/">
<rdf:Description about="http://www.miktex.org/packages/uni-wtal-get">
<TPM:Name>uni-wtal-get</TPM:Name>
<TPM:Creator>mpc</TPM:Creator>
<TPM:Title>Citation style for literary studies at the University of Wuppertal.</TPM:Title>
<TPM:Version>0.1</TPM:Version>
<TPM:TargetSystem></TPM:TargetSystem>
<TPM:Description>The package defines a biblatex citation style based on the author-title style of biblatex-dw. The citations are optimised for literary studies in faculty of humanities at the Bergische Universität Wuppertal.</TPM:Description>
<TPM:RunFiles size="8916">texmf\bibtex\bib\uni-wtal-ger\germanistik.bib texmf\tex\latex\uni-wtal-ger\uni-wtal-ger.bbx texmf\tex\latex\uni-wtal-ger\uni-wtal-ger.cbx texmf\tpm\packages\uni-wtal-get.tpm</TPM:RunFiles>
<TPM:DocFiles size="71811">texmf\doc\latex\uni-wtal-ger\germanistik.pdf texmf\doc\latex\uni-wtal-ger\README</TPM:DocFiles>
<TPM:SourceFiles size="4531">texmf\source\uni-wtal-ger-src.tar.bz2</TPM:SourceFiles>
<TPM:TimePackaged>1304690215</TPM:TimePackaged>
<TPM:MD5>5cfacd1eb764f317970a3f8fabd04455</TPM:MD5>
<TPM:CTAN path="/macros/latex/contrib/biblatex-contrib/uni-wtal-ger"/>
<TPM:Copyright owner="Carsten A. Dahlmann" year="2011"/>
<TPM:License type="lppl1.3"/></rdf:Description></rdf:RDF>

After I deleted this file, I repeated the process of changing the package repository, to force a reread of the package list. The error repeats again.

I looked before posting the related questions to the title of my question and searched for uni-wtal-ger getting zero references.

I use Windows XP SP3 with MikTeX 2.9.

This happened once one year ago and the problem was resolved by someone retiring the difficult package.

Does someone has an idea of how can I restore the package list or should I wait that the list of packages be repaired on the servers?

share|improve this question

closed as too localized by Joseph Wright Jul 17 '11 at 8:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This problem hapens to me, too. I reinstalled MiKTeX, nothing changes. –  Ma Ming May 10 '11 at 0:09
1  
I updated today and had no problems. I'm using the repository at fu-berlin.de. The package manager list doesn't show a uni-wtal-ger package but only uni-wtal-get (which looks like a typo as it contains files with name uni-wtal-ger) and a search on CTAN finds only uni-wtal-get.tar.lzma. Synchronize in the package manager the repository, do it as admin and as user (you can also do it on the command line, see the documentation). –  Ulrike Fischer May 10 '11 at 8:05
    
Good morning. From yesterday on, I had that problem on several Win-Installations, too. There was no matter which repo I used. I even tried a rsync-mirrored (private) aktual updated CTAN.org repo... My way around was using the "Package Manager" - this is working fine for me... Good luck. –  Bastian Ebeling May 12 '11 at 5:24
    
Another strange behaviour: After beeing able to install the package uni-wtal-ger it is again unknown in MiKTeX Options (Admin) Packages (Tab)... –  Bastian Ebeling May 16 '11 at 7:01
    
The correct package should be uni-wtal-ger, but in CTAN, MiKTeX named it as uni-wtal-get see ctan.org/pkg/uni-wtal-ger –  Ma Ming May 16 '11 at 21:07
show 1 more comment

Browse other questions tagged or ask your own question.