Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've got the opportunity to play with a machine with some premium fonts installed. I ran some experiments with XeTeX and e.g. Palatino Linotype, which worked, but for some reason cyrillic breaks with Garamond Premier Pro. The result may be downloaded here.

UPDATE: It turns out the machine had two versions of Garamond Premier Pro installed, one of which apparently has faulty Cyrillic support even though it advertises cyrillic in otfinfo -s. I disabled this version and everything now works fine.

\documentclass[a4paper,12pt]{article}
\usepackage[MnSymbol]{mathspec}
\usepackage{xunicode,xltxtra}

\setmainfont[Mapping=tex-text,Numbers={OldStyle},Ligatures{Common},Contextuals=Alternate]{Garamond Premier Pro}

\begin{document}
Queue stop acte effet shelfful shelf{\null}ful παιδείαὫ $\pi\alpha\phi\Omega$ Черникова ---
\end{document}
share|improve this question
2  
The link is not found. What is the question here? –  ipavlic May 9 '11 at 9:37
2  
I would say either your font is corrupt or you have two versions. Check with \XeTeXtracingfonts/-vv option of xdvipdfmx the fonts your example use. See my answer here: tex.stackexchange.com/questions/15188/… –  Ulrike Fischer May 9 '11 at 10:12
    
If you have found a solution, consider adding it as an answer instead of editing the question. –  Andrey Vihrov May 9 '11 at 12:32
2  
This looks 'too localised' to me –  Joseph Wright May 9 '11 at 13:07
1  
@Joseph: While the specific fonts involved are certainly local the problem itself is rather common. Two versions of the same font (or two fonts with the same name) are the most probable cause when fonts in xetex do "funny" thing. That's why it took me only some seconds to write the answer. –  Ulrike Fischer May 9 '11 at 13:15

1 Answer 1

\XeTeXtracingfonts=1 helped me trace the problem. It turns out that this machine had two versions of Garamond Premier Pro installed. I disabled one (which perhaps had faulty Cyrillic support, even though it advertised it in otfinfo -s…) and now everything is ok.

share|improve this answer
    
A tip: you can use backticks ` to mark your inline code as I did in my edit. –  Andrey Vihrov May 9 '11 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.