Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
\documentclass{article}

\begin{filecontents}{test.bib}
@article{author99,
title = {A fine title},
year = {1899},
author = {An Author and Another Bauthor and Yeta Cauthor},
journal = {Madness}
}
@article{author05,
title = {The best title},
year = {1905},
author = {An Author and More Dauthors and Whois Thisauthor and Heis Thatauthor},
journal = {Insanity}
}
\end{filecontents}

\usepackage[%
  style=authoryear,
  bibstyle=authoryear,
  backend=biber,
  maxbibnames=99,
  maxnames=2,
  firstinits=true,
  uniquename=init]{biblatex}
\addbibresource{test.bib}

\begin{document}
\noindent
\parencite{author99} \\ \parencite{author05}.

\printbibliography
\end{document}

output of above code

As you can see from the image, when the first author is identical, two of the authors are printed in the citation, even if the year of the articles are different. I don't want this, but only the one author, e.g.

(Author et al. 1899)
(Author et al. 1905)

I've tried setting maxcitenames=1, but that didn't make any difference. Is it it possible to achieve this?

Edit: I'm running TeXlive 2010 on Windows 7, Biblatex version 1.4b with Biber 0.9.

share|improve this question
    
When I run your example I get your desired result. Can you explain your problem a little bit better? –  Thorsten May 10 '11 at 13:36
    
@Thorsten: Hmm, I don't. Could it be related to the version of Biblatex? I have v.1.4b of Biblatex, and Biber 0.9 (if that is relevant). –  Torbjørn T. May 10 '11 at 14:26
    
I have an old version ob biblatex and biber. I need to update them. Maybe it's because of this. –  Thorsten May 10 '11 at 14:36
5  
I think there is a bit of misunderstanding about the disambiguation features of biblatex 1.4/biber 0.9 - the name and namelist disambiguation is now (correctly) orthogonal to the year disambiguation. Are you really sure you want what you say you want? That looks like exactly the same group of authors wrote two papers, one in 1899 and one in 1905 which isn't accurate. The automatic namelist disambiguation was designed to expand name lists to the minimal point of unambiguity. Of course you can turn it off but do you really want to? –  PLK May 11 '11 at 15:11
    
@PLK: Good point about unambiguity. It's actually too late to change for the project that was the source of the question, but I'll keep it in mind for the future. –  Torbjørn T. May 11 '11 at 15:28

1 Answer 1

up vote 9 down vote accepted

The observed behaviour is indeed an effect of the full name (and name list) disambiguation introduced in biblatex v1.4. In your example, you partially disabled name disambiguation with the package option uniquename=init, but name list disambiguation is still in effect. To achieve the desired behaviour, add the option uniquelist=false. See the release notes of biblatex for details and instructive examples.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.