Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

After my last update on May 20th 2014, the Miktex Update Wizard give me this error:

The `.tmp` file could not be parsed.



I think that pstool.tmp is the problem. I tried to delete the package, but the problem still appear. I cannot find the folder mik13840 and each time I run the update, the number after "mik" change.

Any idea ?

Thank you in advance

share|improve this question
Your local tpm files are in your miktex tree in tpm/packages. If you try to open pstool.tpm with an xml editor like xml notepad it will complain about "line 2 position 1795". In this position there is an & between the names. Deleting the & will enable you to use the package manager. But not the update manager as it it still will try to parse the online tpm. So make a bug report at the miktex site so that the tpm can be repaired. – Ulrike Fischer May 21 '14 at 7:17
I now made a bug report. – Ulrike Fischer May 21 '14 at 8:54
I haven't this file on my PC. Where I can find it? A "google search" don't help me :-( – user52158 May 21 '14 at 16:40
@texusers123456 You can find it in C:\Program Files\Miktex 2.9\tpm\packages\pstool.tpm. I also have this update problem. The error message poped-up is telling you the cached pstool from remote server cannot be parsed. As Ulrike mentioned, it contains illegal sign & there. – Zachary May 22 '14 at 4:17
i think this is fixed. – Ali May 22 '14 at 6:42

1 Answer 1

The concrete problem has been resolved by an update. But here some background information regarding tpm files and what one can do if one get the error The .tmp file could not be parsed.

tpm-files contain information about a package: version number, included files, where they should be installed etc. tpm-files are xml-files. And if they contain syntax errors then the parsing of the xml can fail, like the "parsing" of a tex-file can fail. Here a faulty & in a name was the problem.

tpm-files exist in two places: After the miktex installation there is a local copy of all existing tpm in the main texmf tree in tpm\packages. The package manager use this tpm to show you e.g. the content of a package (right click ->properties).

These local files are updated when you synchronize. If such a file is faulty after the synchronization you can open it with an xml-editor and correct it. This should at least allow you to use the package manager (as long as you don't try to install the faulty package).

There are also online tpm files. These are used by the update manager. They must be repaired by the miktex maintainer, so one should make a bug report like this

share|improve this answer

protected by Community May 21 '14 at 20:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.