Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In this MWE, Latex doesn't hyphen the word "développement" and prefer to create a HUGE hbox.

\usepackage[a4paper, showframe]{geometry}

% Title Page

 \item [Marhalie Toucse : ]  ingénieure de la plate-forme SORTATZ. Elle réalise 
 le développement du projet des tex écrit pour lipsum lagae legarc sgsi text text text text text text text text text. 

enter image description here

share|improve this question

marked as duplicate by pluton, Thorsten, Christian Hupfer, Masroor, Guido Jun 8 '14 at 16:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

You can manually add a hyphen using \- where you need. // Tu peux ajouter un hyphen manuellement avec \- à l'endroit de ton choix. – Maxime Jun 8 '14 at 14:06
I know that but it's strange that Latex doesn't do it. – user230137 Jun 8 '14 at 14:09
I had exactly the same issue with italian babel with the word "generatori", which is quite popular by the way. So, instead of manually hyphen (which is always good, locally), I used \hyphenation{ge-ne-ra-to-ri} and this solved my problem. – MattAllegro Jun 8 '14 at 14:13
With your code, I do not have this problem. There must be something else in your preamble that perturbates babel and/or french hyphenation. Other suggestion: if you write "ingénieur" without the final "e" (as should be, in my opinion), does it hyphenate? – Bernard Jun 8 '14 at 14:30
The image I posted is the result of the compilation of the MWE I provided. Even if I write "ingénieur" it doesn't hyphenate. By the way ingénieure is the female form of "ingénieur". – user230137 Jun 8 '14 at 14:35

1 Answer 1

up vote 8 down vote accepted

TeX does not allow automatic hyphenation at accents which are constructed from two parts: as set up you are using the OT1 encoding and this means that é is produced using a 'stand alone' acute accent and a normal e. Switching to the modern T1 encoding means that a 'real' é is available, and hyphenation is possible. Indeed, there is a warning in the log with your demo saying

Package frenchb.ldf Warning: OT1 encoding should not be used for French.
(frenchb.ldf)                Add \usepackage[T1]{fontenc} to the preamble
(frenchb.ldf)                of your document, on input line 14.

If you add the line suggested then hyphenation is possible (and occurs).

One way to check this is to


which shows hyphenation positions in the log. Without fontenc you get

[] \OT1/lmr/m/n/12 d^^Seveloppement

where ^^ is the accent and notable there are no break points. In contrast, add fontenc with the T1 encoding and you see

[] \T1/lmr/m/n/12 d�-ve-lop-pe-ment

with valid break points (pdfTeX is still 8-bit so can't show the é properly in the log!).

For more on this, see for example Why words with accented characters can't be automatic hyphenated with the default OT1 enconding? and Why should I use \usepackage[T1]{fontenc}?.

share|improve this answer
I always see that warning but I never known what does it mean. Thanks for the explanation. – user230137 Jun 8 '14 at 15:08
@user230137 do you mean OT1 encoding should not be used for French? if so you're forgiven for not understanding it ... but it does give a solution to the problem on the next line: Add \usepackage[T1]{fontenc} to the preamble of your document ... do that and the warning will go away and hyphenation will be more nearly accurate. – wasteofspace Jun 8 '14 at 15:26
I use kile and I haven't seen Add \usepackage[T1]{fontenc} to the preamble of your document. – user230137 Jun 8 '14 at 15:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.