Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have this :

\documentclass[translator={frenchb}]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[frenchb]{babel}
\PassOptionsToPackage{frenchb}{translator}
\usepackage{pgfgantt}
\usepackage{tikz}


%\usepackage{concrete}
\usetheme{Goettingen}
\begin{document}
\begin{frame}[fragile]
\uselanguage{French}
\languagepath{French}

 \scalebox{.42}{
\begin{tikzpicture} % optional
   \begin{ganttchart}[x unit=2.2mm, 
                      y unit chart=1.2cm, 
                      time slot format=isodate, 
                     ]
                      {2014-04-14}{2014-07-11}
   \gantttitlecalendar{month=name} \\      
   \end{ganttchart}
\end{tikzpicture}
}

\end{frame}

\end{document}

I can't mange to print the month names in French. Normally I have just to load translator package with the frenchb option (look at this answer). This package is already loaded by beamer so I tried \PassOptionsToPackage{frenchb}{translator} but it's not working. How can I fix that?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

\PassOptionsToPackage has to be used before the package is loaded:

\PassOptionsToPackage{frenchb}{translator}
\documentclass{beamer}

Or frenchb can be given as global option:

\documentclass[frenchb]{beamer}
share|improve this answer
    
Was just writing the same, but I'd use just french :-) –  Joseph Wright Jun 9 at 9:21
    
Thanks I didn't know that I can put commands before \documentclass! –  user230137 Jun 9 at 9:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.