Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using Biblatex and having trouble getting an @ONLINE to cite correctly in the bibliography. Here's the preamble:

\documentclass[a4paper,12pt]{scrartcl}
\usepackage[style=authoryear]{biblatex}
\usepackage{hyperref}
\addbibresource{soarBib}

I have an entry in my bibliography that looks like this:

@ONLINE{Google5gram,
    author = {Alex Franz and Thosten Brants},
    organization = {Google Machine Translation Team},
    url = {http://googleresearch.blogspot.com/2006/08/all-our-n-gram-are-belong-to-you.html},
    title = {All Our N-Gram are Belong to You},
    month = aug,
    year = {2006},
}

After \printbibliography, the citation gets printed without any url in the bibliography, like this: "Alex Franz and Thosten Brants. Google Machine Translation Team." How do I get it to print the date and URL?

share|improve this question

closed as too localized by lockstep, Caramdir, Joseph Wright May 28 '11 at 8:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Bases on your answer, I've closed the question as 'too localized'. –  Joseph Wright May 28 '11 at 8:15
add comment

2 Answers

Very strange, I've tested what you are doing, and I'm getting printed the url in the reference section.

By the way, I'm using pdflatex and compile the bib file with bibtex.

The minimal test I did is this:

\documentclass[a4paper,12pt]{scrartcl}
\usepackage[style=authoryear]{biblatex}
\usepackage{hyperref}
\addbibresource{test}

\title{Minimal test}
\date{}

\begin{document}
\maketitle
\nocite{Google5gram}
\printbibliography
\end{document}

Perhaps you could see in detail the logfile you get when compiling your latex file.

share|improve this answer
1  
Yours works for me as well. Time for some investigation... –  Nate Glenn May 17 '11 at 23:33
    
You could show your preamble, so we can see it and perhaps someone knows what is happening... –  Nicolás May 18 '11 at 5:02
    
The problem went away when I restarted my IDE (TexMaker). Not sure if I should delete this post or post this as my answer... –  Nate Glenn May 21 '11 at 2:35
    
@Nate: Please add an answer and accept it. –  Caramdir May 28 '11 at 0:58
add comment
up vote 0 down vote accepted

This problem resolved itself when I restarted my IDE (TexMaker).

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.