Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently purchased an expert font, Calluna (exljbris). There is only one problem when using the font:

The font is encoded with Old Style numbers by default. I don't know how to access the Lining Numbers.

I've tried using Use Old Style Figures thinking the font encoding was switched, but alas, it doesn't work; it stays in Old Style. I have also tried \fontspec[Numbers={Lining}]{Calluna} in the preamble and that hasn't worked.

I use LyX 2.1.0; Windows 8.1; I use XeTeX and \fontspec package.

The Lining Numbers exist in the encoding; it is on the foundry's website, and I also tested it with Microsoft Office 2013 which has the option available.

My LaTeX preamble looks like:

\widowpenalty=10000
\clubpenalty=10000
%\raggedbottom
%\usepackage{dtklogos}
\usepackage{fontspec}
\setmainfont[Ligatures={Historic,Rare,Discretionary,TeX},Contextuals=Swash]{Calluna}
%\pagenumbering{roman}
\usepackage{microtype}
share|improve this question
2  
Welcome to TeX SE. Please complete your code to make a complete, small compilable document so that others can reproduce the problem easily. (I can't as I don't have the font but hopefully others will.) I don't know much about Windows but on OS X, you can use otfinfo -f to get a list of the features provided by the font (in case it is using some non-standard name). [Also on GNU/Linux etc. but they don't have Word so I guess you are on Win or Mac.] –  cfr Jun 15 at 21:41
1  
I have Calluna and, with both xetex and luatex, I get lining numbers when adding Numbers={Lining} to \setmainfont[Ligatures={Historic,Rare,Discretionary,TeX},Contextuals=Swash]{Cal‌​luna}. Please add a complete document illustrating the problem, and details about the version of Calluna that you have. –  Thérèse Jun 15 at 21:45
    
I used the above suggestion of putting Numbers={Lining} into the font specification, and it worked. –  Josh N. Jun 15 at 23:16
    
As for @cfr , If the question wasn't answered so quickly, I would upload a small file or example. I will definitely do that next time. –  Josh N. Jun 15 at 23:23

1 Answer 1

up vote 5 down vote accepted

Without a minimal working example, this answer must be an untested guess, but the problem seems to be that you tried \fontspec[Numbers={Lining}]{Calluna} in the preamble instead of

\usepackage{fontspec}
\setmainfont[Numbers=Lining]{Calluna}

\fontspec[Numbers={Lining}]{Calluna} would be appropriate for one-time use. E.g., if for some reason you wanted Calluna with lining numbers only in one quote, you could write

\begin{quote}
\fontspec[Numbers={Lining}]{Calluna}
12345
\end{quote}

That’s very far from being the most efficient way to change font, but it does work. In the preamble, however, you want \setmainfont with its arguments.

By the way, Ligatures=Rare and Ligatures=Discretionary are two ways of saying the same thing, so choose one. And Calluna does not have the hlig or cswh features, so remove Ligatures=Historic and Contextuals=Swash, otherwise your log file will fill up with distracting warnings. You could add Contextuals=Alternate, but calt should be on by default in xetex.

If you have both the serif and the sans, I would suggest using the font this way:

\defaultfontfeatures{Contextuals=Alternate,Ligatures={TeX,Rare},Numbers=Lining,SmallCapsFeatures={Kerning=Uppercase}}
\setmainfont{Calluna}
\setsansfont{Calluna Sans}

Even better, since the rare ligatures suggest a typographic tradition in which lining figures were not the default, I’d either use the old-style figures, or omit the rare ligatures.

share|improve this answer
    
Yes, inefficiency is a problem with my LaTeX preamble. I have set \defaultfontfeatures to what you have described. I apologize; I'm slowly integrating into exclusive LaTeX. The latter half of the answer is what worked; I tried using: \usepackage{fontspec} \setmainfont[Numbers=Lining]{Calluna} –  Josh N. Jun 15 at 23:15
    
I just realized same person was issuing the answer. –  Josh N. Jun 15 at 23:21
    
I just noticed, when using the above settings, in LyX, the double quotes get all messed up. The standard curly quotes do not work anymore. When I use my example, but just add Numbers=Lining It produces ```` and " respectively in the output. The only time I can get curly quotes is to use my example, but just insert Numbers=Lining, but I want to get standard Ligatures. Should I open a new case? –  Josh N. Jun 15 at 23:52
1  
No, just add Ligatures=TeX to \defaultfontfeatures{}. You used it in your question; sorry, I forgot to include it in my answer, because I always type the curly quotes directly. Will fix my answer. –  Thérèse Jun 15 at 23:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.