Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In my .pdf output document the last of my subchapters does not appear in the table of contents. All the chapters are in different .tex files, which are included into a main file.

All of them are correctly listed in the table of contents, just not the last one.

It is listed in the contents which I can navigate to using Adobe Acrobat.

Here is what the build output says:

As you can see it shows additional output for the subchapter 2.4.2 which is not listed in the table of contents. For every other chapter there is no such output.

pdflatex.exe> (C:\ST\Papers/atl.tex [9])
pdflatex.exe> (C:\ST\Papers/comm.tex
pdflatex.exe> ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ae\omsaer.fd") [10])
pdflatex.exe> (C:\ST\Papers/sparx.tex) [11
pdflatex.exe> \@writefile{toc}{\contentsline {subsection}{\numberline {2.4.2}Sparx Systems En
pdflatex.exe> terprise Architect}{11}{subsection.2.4.2}}
pdflatex.exe> \newlabel{ch:RelatedWork:sec:Commercial:subsec:EA}{{2.4.2}{11}{Sparx Systems En
pdflatex.exe> terprise Architect}{subsection.2.4.2}{}}
pdflatex.exe> ] (C:\ST\conclusion.tex

I already googled for the \@writefile{toc} line, but could not find any help online so far.

share|improve this question
2  
Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. –  Christian Hupfer Jun 18 at 8:09
1  
I'm trying to abstract my project, but it's provided by my university and therefore very huge. But I found out it seems to be related to the command I put around the include commands: \begingroup \let\clearpage\relax .. I used this to prevent Latex to put every section on a new page. If I don't use it then the last subcsection is also shown in the table of contents –  PogoMips Jun 18 at 8:23
    
It looks that you are using \include, but have disabled \clearpage. Then it is a duplicate: Reference label with included file and relaxed clearpage –  Heiko Oberdiek Jun 18 at 8:27
    
@Heiko, that seems helpful at first glance. will investigate later. thx –  PogoMips Jun 18 at 8:30
1  
@PogoMips Don't use \include, it's that easy; change all of them into \input and live happy. No need of \begingroup\let\clearpage\relax, of course. –  egreg Jun 18 at 9:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.