Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use LyX with XeTeX, and the output font is DejaVu Sans. When I write in the input text 'fi' or 'fl', the output text displays a strange big "S"-like symbol. I don't know why is that. Any help would be appreciated.

share|improve this question
    
You will have to give more informations. A picture of your strange "S", a minimal example, log-file ... Did you try the font and the input in another application? –  Ulrike Fischer May 19 '11 at 8:32
    
show the font setting in your document preamble –  Herbert May 19 '11 at 8:36
1  
If you want to disable all ligatures, try \setmainfont[Ligatures=NoCommon]{DejaVu Sans} –  Ma Ming May 19 '11 at 23:42
    
@Ulrike Fischer - it works in vim –  chimil May 20 '11 at 13:50
    
@Herbert I have \usepackage{fontspec}, \usepackage{xltxtra}, usepackage{xunicode}. I used setmainfont in the document (by pressing ctrl+L and {\setmainfont{DejaVu Sans}) –  chimil May 20 '11 at 13:54

1 Answer 1

if I put this

\usepackage{fontspec}
\setmainfont{DejaVu Sans}

into Documents->Setting->Preamble, I'll get a document with correct ligatures, when viewing the pdf

enter image description here

share|improve this answer
    
It didn't work for me, I had to follow Ma Ming's advice and switch off the Ligatures. Do you know whether there's a setting (I couldn't find) to switch them off by default? –  chimil May 20 '11 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.