Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Since updating to TeX-Live 2013 I am facing the following error:

Compiling the following file by XeLaTeX ...

\documentclass{scrbook}
\usepackage{fontspec}
\begin{document}
 bla
\end{document}

... ends up with

! Undefined control sequence.
<argument> \str_if_eq_x_p:nn 

l.5 \end{document}

Replacing scrbook by scrartcl or scrreprt works smoothly. Also in my old TeX-Live 2012 installation the problem does not occur.

share|improve this question

closed as off-topic by Joseph Wright Apr 11 at 22:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Joseph Wright
If this question can be reworded to fit the rules in the help center, please edit the question.

    
You have mismatched versions of fontspec and l3kernel (expl3): nothing to do with KOMA per se (probably showing up as a different path is taken in the code). Can you post your log file as an edit? –  Joseph Wright Jun 21 '14 at 14:04
1  
Oh my goodness. I happened to have all the l3-packages in my $(HOME)/texmf file. Therefore the version mismatch occured. I could have figured this out myself by checking the logfiles more carefully. Thanks so much, problem solved. –  Johannes Jun 21 '14 at 14:10
1  
I suspected something like that: this is quite a common one :-) –  Joseph Wright Jun 21 '14 at 14:10