Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For a publisher I have to generate a pdf file which does not contain any Type3 fonts.

Until now I thought that using pdflatex on current LaTeX distributions should be enough to get a pdf file without any Type3 fonts, but for the current document this is not true:

$ pdffonts paper.pdf
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
ZFUCHW+NimbusRomNo9L-Medi            Type 1            yes yes no      41  0
VNQOQC+NimbusRomNo9L-Regu            Type 1            yes yes no      42  0
[none]                               Type 3            yes no  no      43  0
NXAFJF+NimbusRomNo9L-ReguItal        Type 1            yes yes no      46  0
CBNMRR+NimbusRomNo9L-MediItal        Type 1            yes yes no      48  0
MNSAJN+NimbusRomNo9L-Regu-Slant_167  Type 1            yes yes no      52  0
FJTKHV+CMSY7                         Type 1            yes yes no      53  0
VVITQE+CMMI9                         Type 1            yes yes no      54  0
CHSHRJ+CMR9                          Type 1            yes yes no      56  0
EAPUQB+CMR6                          Type 1            yes yes no      57  0
KBHVYI+CMMI6                         Type 1            yes yes no      58  0
EHULJT+CMTI9                         Type 1            yes yes no      59  0
JLLCEK+CMSY9                         Type 1            yes yes no      61  0
YEIEPQ+CMEX9                         Type 1            yes yes no      64  0
DFKMIY+CMSY8                         Type 1            yes yes no      84  0
NEDAGG+CMSY6                         Type 1            yes yes no      87  0
QDTWCG+MSBM10                        Type 1            yes yes no     127  0
[none]                               Type 3            yes no  no     198  0
OKAOPP+CMMI8                         Type 1            yes yes no     199  0
TIGOKK+CMR8                          Type 1            yes yes no     200  0
GWSFMB+CMTI8                         Type 1            yes yes no     201  0
[none]                               Type 3            yes no  no     397  0

I am surprised that all the Type3 fonts haven't a real name.

The document uses the sigplanconf documentclass. For figures only the tikz and listings packages are used (no graphicx package is used, i.e. no \includegraphics is used and no postscript files are embedded).

I am using Ubuntu 10.04 with TeX Live:

$ pdflatex --version
pdfTeX 3.1415926-1.40.10-2.2 (TeX Live 2009/Debian)

I have found an ACM FAQ about Type1 fonts, but it seems to be outdated and the suggested method still yield pdf files with Type3 fonts.

pk fonts: Looking for pk fonts in the doc.log find I found this ouput:

 75i,27n,56p,866b,2711s stack positions out of 5000i,500n,10000p,200000b,50000s
 </mnt/max/.texmf-var/fonts/pk/ljfour/jknappen/ec/ectt0800.600pk> </mnt/max/.texmf-var/fonts

What could be reasons for this? Is some font package missing? Or has it something to do with tikz?

share|improve this question
Installing the cm-super fonts package seems to be the easy answer to me. – user18839 Sep 17 '12 at 20:18
@Ryan, this is already mentioned in an upvoted comment of the accepted answer. Please upvote it as well. You could even post a new short answer to the same effect - which I would upvote. – maxschlepzig Sep 20 '12 at 18:11

3 Answers 3

up vote 5 down vote accepted

Look at the end of the log-file of pdflatex. It will tell you which fonts are included and which are bitmap (pk) fonts.

share|improve this answer
Thanks, I've found some pk fonts the log file (see the update) - I have no real idea, where they are coming from, though ... – maxschlepzig May 20 '11 at 13:27
Install the cm-super fonts. – Ulrike Fischer May 20 '11 at 14:02
thanks a lot, with the cm-super package installed there aren't any Type3 fonts included anymore in the pdf file. – maxschlepzig May 20 '11 at 14:09
The bbm package, which you might want to use to write blackboard bold numbers, is a source of Type 3 fonts. Try the dsfont package instead. – nemarona May 27 at 15:42

A Type 3 font is not by default a bitmap font. It means only not a Type 1 one. This is the reason why a Type 3 font can also be a vector font. If there is no listed pk font in the log file, then you have such a type 3 font included. It may also be loaded by an image with \includegraphics

share|improve this answer
Ok, I've found some pk fonts and I am not using includegraphics (updated the question). – maxschlepzig May 20 '11 at 13:29
then show exactly your font setting in the preamble. However, it looks like that you are using the package times instead of mathptmx. Right? – Herbert May 20 '11 at 14:00
no, I am not using the times package - the system was missing the cm-super package - see my comment to Ulrike Fischer's answer. – maxschlepzig May 20 '11 at 14:12

First off, most people use pdflatex nowadays. Change every image to pdf if possible replacing eps files by pdf using

     convert file.eps file.pdf

convert is found in the imagemagick package. Remove epsfig and use includegraphics instead.

Next run:

     pdffonts final_upload_document.pdf | less

to ensure that a type 3 font problem is actually the issue. If it isn't then the problem is most likely related to spaces in file names.

Next run:

     pdffonts each_image.pdf

to find any type 3 fonts on the individual pdf files to find which image is causing the problem. It could be an xfig or matlab problem, or a problem from another image generator.

If the contained pdfs don't create the issue, then it is most likely an include such as blackboard fonts that is causing the problem inside the source latex file.

Using the above method I found in particular that xfig in addition to matlab can cause the same artefacts if you are using export to latex+pdf part.

When you find the pdf + latex file you can run:

  xfig -specialtext -latexfonts -startlatexFont default

to start up xfig with the right settings. You also might find as in my case that the xfig image was generated some years ago that was to go into the paper, and that it now doesn't even open in newer versions of xfig giving a sigsegv fault. In this case your only option is to regenerate the image using the above xfig call.

share|improve this answer
Very interesting, I found the exact source of the xfig Type 3 font problem. It occurs not in the text fonts, but in the patterned polylines. If you use filled instead of patterned polylines and export to pdf/latex, you will then find that pdffonts will not return a type 3 font on your pdf. – Eamonn Kenny Nov 12 at 12:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.