Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How is it possible to define the fontsize in documents written in Greek? I am using TexnicCenter and Miktex and trying the following example

\documentclass{article} 
\usepackage[utf8]{inputenc}
\usepackage[LGRx,T1]{fontenc}
\usepackage[english,greek]{babel}

\begin{document}

Ελληνικό Κείμενο 

\end{document}

the output is fine. However once I combine two languages, for example

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[LGRx,T1]{fontenc}
\usepackage[english,greek]{babel}

\begin{document}

Ελληνικό Κείμενο \selectlanguage{english} English Text

\end{document}`

the english part just looks terrible in the pdf (pixelated). Similarly if I try to set the fontsize in the beginning, the same happens for the greek part of the text.

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[LGRx,T1]{fontenc}
\usepackage[english,greek]{babel}

\begin{document}

Ελληνικό Κείμενο

\end{document}`

I cannot really tell what causes this. Should I be using a different font? Are there some settings that should be used to make everything look OK?

As I was looking for possible solutions I also came across this document that tries to describe some guidelines for the greek language for a different package, but the pdf itself has the same issues (just zoom in and notice the greek text) lgreekuse.pdf.

Also here in this document, greek-usage.pdf the greek fonts have exactly the same issues.

share|improve this question
    
After some more searching, I found the greek fonts that are available from the greekfontsociety http://www.greekfontsociety.gr/ and after installing and using one of them, the text seems fine both in english and greek. This does not happen, however, for the default settings as I mentioned above. –  o4tlulz May 21 '11 at 3:28
add comment

1 Answer 1

up vote 2 down vote accepted

To get type1 fonts in the english part: Install the cm-super fonts or use \usepackage{lmodern}. To get type1 fonts in greek for sizes other than 10pt see polutonikogreek with lmodern 12pt.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.