Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Within a document in ngerman or english, I'd like to have some Greek text using babel's polutonikogreek. It seems there are two options for including greek text:

\textgreek{mikra'iti mouse~ion}

which seems good for single words and short passages, and for longer passages

\selectlanguage{polutonikogreek} mikra'iti mouse~ion

Using my standard setup (cf. below) including \documentclass[12pt]{article}, both options produce ugly pixelated output, technically speaking, it uses a Type 3 font, which doesn't happen for normal text:

pixelated greek

This problem doesn't appear when using 10pt, in this case, a Type 1 font is used.

How do I get Type 1 fonts for polutonikogreek in 12Pt (and other sizes)? Here's my setup / a MWE:

\documentclass[12pt]{article}
\usepackage[polutonikogreek,english]{babel}
\usepackage[T1]{fontenc}
\usepackage{lmodern}

\begin{document}

\textgreek{mikra'iti mouse~ion}

\selectlanguage{polutonikogreek} mikra'iti mouse~ion

\end{document}

I use pdfTeX 1.40.11 by MiKTeX 2.9

Interestingly, this issue appears even in a manual for the greek option in babel, so it doesn't seem to be trivial. Then again, the manual is from 1997.

P.S.: You'll notice there's also an issue with the circumflex accent, but I thought I'd post this as a separate question once this one's solved.

share|improve this question
    
what does your log file say about the loaded fonts? See end of the log file –  Herbert May 21 '11 at 13:52
    
As for the circumflex accent issue, this seems to be expected for \textgreek{}: "Please note that certain symbols cannot have their expected result for Greek text, unless someone has selected the Greek language, e.g., ~ is such a symbol." (from Writing Greek with the greek option of the babel package, p. 3) –  doncherry May 23 '11 at 20:38
add comment

3 Answers

up vote 6 down vote accepted

The cheep method to solve this is to tell (pdf)latex to use grmn1000.pfb for all sizes:

\documentclass[12pt]{article}

\usepackage[polutonikogreek,english]{babel}

\usepackage[T1]{fontenc}
\usepackage{lmodern}
\DeclareFontFamily{LGR}{lmr}{}
\DeclareFontShape{LGR}{lmr}{m}{n}
  {<-> grmn1000}{}

\begin{document}

\textgreek{mikra'iti mouse~ion}

\selectlanguage{polutonikogreek} mikra'iti mouse~ion

\end{document}

You will need more \DeclareFontShape command for bold etc. Look in lgrlmr.fd for a list.

The other possibility is to install the full set of the cbfonts. As far as I know there is no miktex package so you will have to do it manually. Get cbfonts.zip from CTAN (~70MB!), unzip it somewhere outside the miktex folders. You will get a folder

cbfonts/fonts/map
             /type1
             /....  
       /tex

In cbfonts/fonts/map there is a cbgreek-full.map. Move it to cbfonts/fonts/map/dvips (miktex seems to ignore maps directly in fonts/map).

Then add the root folder cbfonts as a new root in miktex settings as in admin mode (for all users) or user mode (only for you). Call on the command line initexmf --admin --edit-config-file updmap (admin mode) or initexmf --edit-config-file updmap (user mode) which will open a updmap.cfg. Add Map cbgreek-full.map, save it. Then run updmap --admin or updmap. After this your example should use grmn1200.pfb for the 12pt greek.

share|improve this answer
    
I tried to install cbfonts, but it still doesn't work. I downloaded cbfonts.zip, and did all your steps. My example still uses the same font (I think grmn1200.pk). Possible sources for confusion: 1) I have the multi-user install of MiKTeX. 2) Folder names cbfonts vs. cb, see Leo Liu's post. 3) Should I add Map cbgreek-fullmap or Map cbgreek-fullmap.map to updmap.cfg? The other entries list the file extension (Map clm.map and Map libertine.map -- another potential source of the problem?) –  doncherry May 21 '11 at 16:32
    
Yes, sorry I had a type it should be Map cbgreek-fullmap.map. I edited my answer. And I added instructions for multiuser setup (as I have a singleuser installation I can't test them but imho they should be correct.) –  Ulrike Fischer May 22 '11 at 8:41
    
Nope, still nothing. I just did a complete reinstall of MiKTeX because something got messed up along the way and nothing was working anymore, and then went through your instructions A–Z again (both single user and admin), but still no new font. Is it possible that there's interference with cfr-lm, that I installed according to the question Oldstylenums with Latin Modern? (Btw, your cheap method works, but I'd really like to have the real thing working.) –  doncherry May 22 '11 at 11:11
1  
I think I got it: I didn't forget a map in my first answer but simply a dot. The name of the map-file is cbgreek-full.map. So correct the updmap.cfg –  Ulrike Fischer May 23 '11 at 18:08
2  
Yes! This did it! Thank you so much! To keep this question decently clean, should we delete all the comments once you've edited your answer? (You can also removed the differentiation between user and admin, I made the edit as a user, so it doesn't seem to make any difference) –  doncherry May 23 '11 at 18:21
show 6 more comments

I can’t see any problems with your MWE. My Setup ist MacTeX (~ TeX Live 2010) width pdflatex 3.1415926-1.40.11 maybe you need to update your system?! enter image description here

My file list

get it with \listfiles before the \documentclass command

*File List*
article.cls 2007/10/19 v1.4h Standard LaTeX document class
size12.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
babel.sty 2008/07/06 v3.8l The Babel package
greek.ldf 2005/03/30 v1.3l Greek support from the babel system
lgrenc.def 2008/06/17 v2.3 Greek Encoding
english.ldf 2005/03/30 v3.3o English support from the babel system
fontenc.sty
t1enc.def 2005/09/27 v1.99g Standard LaTeX file
lmodern.sty 2009/10/30 v1.6 Latin Modern Fonts
lgrcmr.fd 2008/06/17 v2.3 Greek Computer Modern
t1lmr.fd 2009/10/30 v1.6 Font defs for Latin Modern
lgrlmr.fd 2008/06/17 v2.3 Greek Latin Modern
share|improve this answer
    
@Tobi: I just ran an update and there was nothing to update. I think it might have something to do with the fonts I have installed, or rather the ones I don't. –  doncherry May 21 '11 at 13:49
    
@doncherry: I added my file list to my answer so you can compare it with yours. –  Tobi May 21 '11 at 13:58
    
I checked my file list, it wasn't different in any important respect. It seems the problem was MiKTeX-specific. Thanks for your help though! –  doncherry May 23 '11 at 20:43
    
@doncherry: Sorry, that it didn’t help … but I’m glad to see that Ulrike solved you problem :-) –  Tobi May 23 '11 at 22:49
    
Don't worry, it was interesting seeing that this seems to work better with TeX Live, and I learned about \listfiles, which I hadn't known before. –  doncherry May 24 '11 at 14:15
show 1 more comment

It seems that some fonts are not installed properly. It is not very easy to examine the problem, and I don't use MiKTeX (but TeX Live).

Anyway, search your MiKTeX directory for these files.

These should exist, since you compiled the document without errors:

  • lgrlmr.fd at ???/tex/generic/babel/
  • grmn1200.tfm at ???/fonts/tfm/public/cbfonts/

And this may be absent:

  • grmn1200.pfb at ???/fonts/type1/public/cbfonts/ (Type1 font for Greek Latin Modern 12pt)

If the .pfb file does not exist or at a wrong position, you should reinstall cbfonts package using MiKTeX's Package Manager, or install it manally.

If the file is OK, this may be wrong:

  • pdftex.map at ???/fonts/map/pdftex/updmap/ with a line:

    grmn1200 grmn1200 <grmn1200.pfb
    

You may need to edit the updmap.cfg and run updmap utility to make the fonts valid.


From your comment and packages in CTAN/systems/win32/miktex/, it seems that MiKTeX has no full latest cb fonts for greek, but only the fonts for 10pt.

You'd better write a letter to MiKTeX mailing list to report the problem and ask for update.

And if you want to use the fonts now, you must install the full fonts manually from CTAN. It isn't easy for newbies, indeed.

You can get all fonts at:
http://www.ctan.org/tex-archive/fonts/greek/cbfonts-all

  1. Extract all the files and copy them to the MiKTeX's TDS root directory.

  2. Run updmap following Ulrike Fischer's advice. The key is to add cbgreek-full.map and make it active.

  3. Use it.

share|improve this answer
1  
1) lgrmlr.fd is present. 2) ???/fonts/tfm/public/cbfonts/ doesn't exist, but there is ???/fonts/tfm/public/cb/. The latter doesn't contain grmn1200.tfm, but grmn1000.tfm. 3) Again, there's just ``???/fonts/type1/public/cb`, which contains only grmn1000.pfb. 4) As for cbfonts, afaik this isn't a package, but a font collection, which is why it doesn't show up in the package manager nor can be installed as a package manually? 5) ???/fonts/map/pdftex/updmap doesn't exist either. I've updated updmap.cfg several times while trying Ulrike's advice. That's all pretty strange? –  doncherry May 21 '11 at 16:10
    
There should be some naming differences between MiKTeX and TeX Live, it doesn't matter. However, grmn1000.pfb and grmn1000.tfm are fonts of 10pt, there's no fonts for 12pt. I checked MiKTeX's cbgreek.cab in CTAN, it's old and incomplete. That's MiKTeX's issue. –  Leo Liu May 21 '11 at 16:46
    
Or, if you don't mind, you can use TeX Live instead. Personally, I prefer TeX Live than MiKTeX. (MiKTeX has its advantage, of course.) –  Leo Liu May 21 '11 at 16:59
    
Thanks for your help, as you suggested, Ulrike's advice has solved the issue. I'm indeed considering switching to TeX Live, I'll have to look into it some time. –  doncherry May 23 '11 at 20:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.