Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

tkz-fct produces no plots, for instance I copied the following code from the manual:

    \documentclass{article}

    \usepackage{color}
    \usepackage{tikz}%
    \usepackage{tkz-euclide}
    \usepackage{tkz-fct} \usetkzobj{all}

    \begin{document}
    \begin{tikzpicture}[scale=.5]
    \tkzInit[xmax=100,xstep=10,
    ymax=1000000, ystep=100000]
    \tkzAxeX[right] \tkzAxeY[above]
    \tkzGrid \tkzFct[color=red,
    domain=0:100]{\x**3}
    \end{tikzpicture} 
    \end{document}

This results in the following picture:

enter image description here

gnuplot --version gives: gnuplot 4.4 patchlevel 2

Any ideas how to solve the problem?

share|improve this question
    
To complete my answer, you can search gnuplot in you system to verify if gnuplot works correctly. Then you need to use pgf 2.1 with tkz-base, fct etc. and the option "--shell-escape" is necessary to allow the execution of Gnuplot. There are several answers about this problem. –  Alain Matthes May 21 '11 at 15:44
    
Thanks, the --shell-escape option was missing! –  student May 21 '11 at 16:42
add comment

1 Answer

up vote 4 down vote accepted

Your code works :

enter image description here

You need to read your .log file to verify two things: 1) the path for gnuplot . If the path is fine then you must find a line like gnuplot executed or something like that 2) if in your .log file, you have something like file.table not found, then you need to use the option --shell-escape or write18 in your script for the compilation. The problem is the same with pgfplots or another package that uses gnuoplot

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.