Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just downloaded TL 2010 but the packages don't seem available to TexWorks. Before I was using the version of TL supplied via Synaptic. But that was not being kept up to date so I had to download TUGs version into what will be a separately maintained directory.

But I don't know how to configure my editors (TexWorks is the primary editor I use, TexMaker is my secondary editor) to be able to tap into the new package repository I've created. I'm working within Debian Squeeze.

I used default paths in my installation.

It was suggested I edit the .profile file - this is where I'm at at the moment:

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

PATH=/usr/local/texlive/2010/bin/i386-linux:$PATH 

MANPATH=/usr/local/texlive/2010/texmf/doc/man:$MANPATH 

INFOPATH=/usr/local/texlive/2010/texmf/doc/info:$INFOPATH
share|improve this question
1  
TL 2011? not 2010 (the current version)? –  Caramdir May 21 '11 at 23:15
    
Did you add the necessary TeX Live paths (in the .profile directory)? –  Gonzalo Medina May 21 '11 at 23:19
    
@Caramdir Thanks, I meant 2010. OP edited with that correction now. –  ptrcao May 21 '11 at 23:38
    
@Gonzalo Medina ".profile directory", where do I find that? –  ptrcao May 21 '11 at 23:38
    
It's usually in /home/your_user_name/; you need to edit this file and add something like PATH=/usr/local/texlive/2010/bin/x86_64-linux:$PATH MANPATH=/usr/local/texlive/2010/texmf/doc/man:$MANPATH INFOPATH=/usr/local/texlive/2010/texmf/doc/info:$INFOPATH the last part of the first line can be different in a 32bit installation. –  Gonzalo Medina May 21 '11 at 23:43
show 11 more comments

1 Answer 1

I'm working with Debian Squeeze, TL2010 and TeXworks, too.

This is how I did it:

  1. Use synaptic to uninstall all packages starting with "texlive-"
  2. Download and unpack TL2010 installer
  3. Open "Root Terminal, start installer with "./install-tl"
  4. Select option "Create symlinks to standard directories" (by using this there is no need to edit any files like .profile)
  5. Start installation of TeXlive
  6. Test TeXlive with "pdflatex sample2e"
  7. "apt-get update" and "apt-get install perl-tk perl-doc equivs"
  8. Create and install texlive-local_2009-1_all.deb (see http://www.tug.org/texlive/debian.html)
  9. "apt-get install texworks" (this should NOT install any TeX related packages except texworks itself!)
  10. Test TeXworks
  11. "tlmgr update --all" (to test if the update mechanism of TeXlive works fine)
share|improve this answer
    
I used the GUI wizard install; I don't remember getting a create symlinks option. Can you clarify the situation with GUI wizard install? –  ptrcao May 22 '11 at 7:21
1  
I don't know where to find this option in the GUI installation wizard, but you can create the symlinks after installation, too. Just start "tlmgr gui" as root and go to the menu "Actions" => "Handle symlinks in system dirs..." –  Axel Sommerfeldt May 22 '11 at 8:30
    
Slight problem you might be able to help with. It's a silly catch 22 situation actually. I need to launch tlmgr as root to have access to config options but tlmgr isn't recognised when I try to launch it as root:- sudo: tlmgr: command not found –  ptrcao May 22 '11 at 9:18
    
Also I get this: peter@debian-peter:~$ tlmgr gui No protocol specified perl/Tk unusable, cannot create main windows. That could be a consequence of not having X Windows installed or started! Error message from creating MainWindow: couldn't connect to display ":0" at /usr/lib/perl5/Tk/MainWindow.pm line 55. Tk::MainWindow->new() at /usr/local/texlive/2010/bin/i386-linux/tlmgr line 3590 –  ptrcao May 22 '11 at 9:59
1  
@Jasper Joy There maybe several factors thwarting my efforts here: first, the path /usr/local/texlive/2010/bin/i386-linux wasn't there in the "Paths for Tex and related programs" menu. So I added it. Second, the package chemmacros was stipulating other packages and the use of something called "\usetikzlibrary{calc}" which I don't understand. Bottom line it finally seemed to work, but because I'd tried so many things at once I'm still unsure what finally did it. Some or all of the above. Thanks everyone for your help. Good grief, now I have to go troubleshoot similar issues on Windows. :| –  ptrcao May 22 '11 at 14:01
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.