Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In advance, I apologise if this is off-topic as "too localised", but I'm not sure where's the best place to ask.

I am running TeX Live 2014 on Windows 7, fully up-to-date as of this morning. Here's my MWE:

% !TEX TS-program = xelatex
% !TEX encoding = UTF-8 Unicode
Hello, World!

which gives me this (partial) log:

! LaTeX error: "kernel/misplaced-equals-sign"
! Misplaced equals sign in key-value input 81
! See the LaTeX3 documentation for further information.
! For immediate help type H <return>.

l.81       {EBGaramond12}

The l.81 in question appears to come from this part of ebgaramond.sty:

      [ Numbers = {\ebgaramond@figurealign,\ebgaramond@figurestyle},
        UprightFont    = *-Regular ,
        ItalicFont     = *-Italic ,
        BoldFont    = *-Regular ,
        BoldItalicFont     = *-Italic ,

For EBGaramond problems, I would normally talk with Bob Tennent, but can't help feeling this case is something else.

Please, a clue, or suggest additional useful diagnostics. I don't think I have a corrupted install, as I installed clean from the ISO three days ago, and did just one tlmgr update --all this morning.

And here's the \listfiles:

 *File List*
 article.cls    2007/10/19 v1.4h Standard LaTeX document class
  size10.clo    2007/10/19 v1.4h Standard LaTeX file (size option)
ebgaramond.sty    2014/07/02 (Bob Tennent) Style file for EB Garamond fonts.
 ifxetex.sty    2010/09/12 v0.6 Provides ifxetex conditional
ifluatex.sty    2010/03/01 v1.3 Provides the ifluatex switch (HO)
 xkeyval.sty    2014/05/25 v2.7 package option processing (HA)
 xkeyval.tex    2014/05/25 v2.7 key=value parser (HA)
textcomp.sty    2005/09/27 v1.99g Standard LaTeX package
  ts1enc.def    2001/06/05 v3.0e (jk/car/fm) Standard LaTeX file
fontspec.sty    2014/06/21 v2.4a Font selection for XeLaTeX and LuaLaTeX
   expl3.sty    2014/06/10 v5105 L3 programming layer (loader) 
expl3-code.tex    2014/06/10 v5105 L3 programming layer 
    etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)
  xparse.sty    2014/06/10 v5105 L3 Experimental document command parser
fontspec-patches.sty    2014/06/21 v2.4a Font selection for XeLaTeX and LuaLaTe
fontspec-xetex.sty    2014/06/21 v2.4a Font selection for XeLaTeX and LuaLaTeX
  eu1enc.def    2010/05/27 v0.1h Experimental Unicode font encodings
  eu1lmr.fd    2009/10/30 v1.6 Font defs for Latin Modern
xunicode.sty    2011/09/09 v0.981 provides access to latin accents and many oth
er characters in Unicode lower plane
 eu1lmss.fd    2009/10/30 v1.6 Font defs for Latin Modern
graphicx.sty    2014/04/25 v1.0g Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2009/02/05 v1.0o Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    1999/03/16 v1.09 sin cos tan (DPC)
graphics.cfg    2010/04/23 v1.9 graphics configuration of TeX Live
   xetex.def    2014/04/28 v4.01 LaTeX color/graphics driver for XeTeX (RRM/JK)

  ts1cmr.fd    1999/05/25 v2.5h Standard LaTeX font definitions
   t3cmr.fd    2001/12/31 TIPA font definitions


And here are the actual file paths from the .log:

) (d:/Programs/TeX.Live/texmf-dist/tex/latex/fontspec/fontspec-xetex.sty

And here's ebgaramond12.fontspec. Looks innocuous:

        Extension = .otf 
        UprightFont    = *-Regular ,
        ItalicFont     = *-Italic ,
        BoldFont    = *-Regular ,
        BoldItalicFont     = *-Italic
share|improve this question
All 'works for me' here: can we see the file locations/versions from your .log? – Joseph Wright Jul 6 '14 at 11:18
ebgaramond12.fontspec looks suspicious: what's in it? – egreg Jul 6 '14 at 11:31
@JosephWright Added! – Brent.Longborough Jul 6 '14 at 11:33
On my sistem I have EBGaramond12.fontspec that's not loaded when running XeLaTeX on the example file. – egreg Jul 6 '14 at 11:36
On the other hand, that .fontspec file is wrong, as it is missing a comma after Extension = .otf – egreg Jul 6 '14 at 11:38

1 Answer 1

up vote 15 down vote accepted

The fontspec package allows for “collections” (see section 6.2 in the doc): a .fontspec file containing font definitions can be written and stored. However, fontspec lowercases the argument when looking for the .fontspec file, so with


the file looked for is ebgaramond12.fontspec. To make things hairier, the distribution of the ebgaramond package contains EBGaramond12.fontspec. On a case sensitive file system, this is not loaded because it's not looked for; to the contrary, a case insensitive file system (Windows) will find it and, indeed, you get entries


in the file list.

Alas, the file contains a syntax error, besides being ill-named:

        Extension = .otf ,% <---------------- MISSING COMMA!
        UprightFont    = *-Regular ,
        ItalicFont     = *-Italic ,
        BoldFont    = *-Regular ,
        BoldItalicFont     = *-Italic

If I copy EBGaramond12.fontspec as ebgaramond12.fontspec in the work directory, I get the same error message as you. This error disappears as soon as I add the missing comma as shown above.

share|improve this answer
That's it! Thank you. – Brent.Longborough Jul 6 '14 at 12:15
Curious! ebgaramond12.fontspec is listed in the eggaramond tlpobj file, but is not in the package tar.xz, nor in the package on CTAN??? How is it created? – Brent.Longborough Jul 6 '14 at 12:30
@egreg: In the only example in the fontspec documentation, a file is named TeXGyreAdventor.fontspec. The missing comma is the real issue. – user51830 Jul 6 '14 at 12:32
@user51830 It's not the only flaw in the manual. However, the package should try both the unchanged argument and the lowercased one. – egreg Jul 6 '14 at 12:57
@egreg — Hmm, now why would I lowercase the font name in general? I have no memory of why this would be necessary! – Will Robertson Jul 7 '14 at 2:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.