Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a big problem. I am writing my phd thesis and started to use latex recently. I developed some basic skills that helped out me most time. But at the moment I dont know how to solve the problem. Every time I try to typeset the tex-file, the console says this:

This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)
 \write18 enabled.
entering extended mode
(./Promotion4.tex
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, dumylang, nohyphenation, ge
rman-x-2009-06-19, ngerman-x-2009-06-19, ancientgreek, ibycus, arabic, armenian
, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danish, dutch, u
kenglish, usenglishmax, esperanto, estonian, farsi, finnish, french, galician, 
german, ngerman, swissgerman, monogreek, greek, hungarian, icelandic, assamese,
 bengali, gujarati, hindi, kannada, malayalam, marathi, oriya, panjabi, tamil, 
telugu, indonesian, interlingua, irish, italian, kurmanji, lao, latin, latvian,
 lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, polish, portuguese, roma
nian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, turkish,
 turkmen, ukrainian, uppersorbian, welsh, loaded.
(/usr/local/texlive/2010/texmf-dist/tex/latex/base/book.cls
Document Class: book 2007/10/19 v1.4h Standard LaTeX document class
(/usr/local/texlive/2010/texmf-dist/tex/latex/base/bk12.clo))
(/usr/local/texlive/2010/texmf-dist/tex/generic/babel/babel.sty
(/usr/local/texlive/2010/texmf-dist/tex/generic/babel/ngermanb.ldf
(/usr/local/texlive/2010/texmf-dist/tex/generic/babel/babel.def)))
(/usr/local/texlive/2010/texmf-dist/tex/latex/base/inputenc.sty
(/usr/local/texlive/2010/texmf-dist/tex/latex/base/applemac.def))
(/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/biblatex.sty
(/usr/local/texlive/2010/texmf-dist/tex/latex/etoolbox/etoolbox.sty
(/usr/local/texlive/2010/texmf-dist/tex/latex/etex-pkg/etex.sty))
(/usr/local/texlive/2010/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/base/ifthen.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/url/url.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/blx-compat.def)
(/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/biblatex.def)
(/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/bbx/authortitle-icomp.bb
x (/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/bbx/authortitle.bbx
(/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/bbx/standard.bbx)))
(/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/cbx/authortitle-icomp.cb
x) (/usr/local/texlive/2010/texmf-dist/tex/latex/biblatex/biblatex.cfg))
(/usr/local/texlive/2010/texmf-dist/tex/latex/csquotes/csquotes.sty
(/usr/local/texlive/2010/texmf-dist/tex/latex/csquotes/csquotes.def)
(/usr/local/texlive/2010/texmf-dist/tex/latex/csquotes/csquotes.cfg)

Package csquotes Warning: Option 'babel' depreciated.
(csquotes)                Using 'autostyle' on input line 2327.

) (/usr/local/texlive/2010/texmf-dist/tex/latex/fancyhdr/fancyhdr.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/hyperref/hyperref.sty
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/etexcmds.sty))
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/pdfescape.sty
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/pdftexcmds.sty
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/ifluatex.sty)))
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/ifpdf.sty)
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/ifvtex.sty)
(/usr/local/texlive/2010/texmf-dist/tex/generic/ifxetex/ifxetex.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/oberdiek/hycolor.sty
(/usr/local/texlive/2010/texmf-dist/tex/latex/oberdiek/xcolor-patch.sty))
(/usr/local/texlive/2010/texmf-dist/tex/latex/oberdiek/letltxmacro.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/hyperref/pd1enc.def)
(/usr/local/texlive/2010/texmf-dist/tex/generic/oberdiek/intcalc.sty)
(/usr/local/texlive/2010/texmf-dist/tex/latex/latexconfig/hyperref.cfg)
(/usr/local/texlive/2010/texmf-dist/tex/latex/oberdiek/kvoptions.sty)

/usr/local/texlive/2010/texmf-dist/tex/latex/hyperref/hyperref.sty:3577: Packag
e keyval Error: cross-reference undefined.

See the keyval package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.3577 \ProcessKeyvalOptions{Hyp}

I tried all the shortcuts to ignore the warnings and errors, but nothing helps. In the end I dont get the pdf-file and I it feels like destroying all the work I have done so far.

So if anyone knows how to fix the problem, that would be great.

share|improve this question
4  
Without a minimal example, we are not going to be able to say what is wrong. –  Joseph Wright May 23 '11 at 16:35
3  
Don't panic. It is an hyperref error and these are always solved fast. Check at first your hyperref version. E.g. in the log. If it is older than mine (2011/04/17 v6.82g) update and then try again. –  Ulrike Fischer May 23 '11 at 16:48
    
@ Joseph: Thanks for the commend. What you touched upon is the next part of the problem. I dont know what minimal example in this case would look like. Shall I provide an example of the preamble? Or a piece of text including some commands? –  Philip May 23 '11 at 16:55
    
@Philip: Have a look at the link Joseph provided. Basically, a MWE is a tex-sample that only contains what's necessary to reproduce the problem. You can get there by stripping your document of elements/parts/things one by one (e.g. starting with big text passages, other packages ...), compiling in between to make sure the problem's still there. This way, you can narrow down the source of the problem. For more details, follow the link. –  doncherry May 23 '11 at 17:17
    
Now that I see the output in a code environment: The problem is probably a wrong option. E.g.\usepackage[cross-reference]{hyperref} would give this error. –  Ulrike Fischer May 23 '11 at 17:21
show 6 more comments

1 Answer

up vote 4 down vote accepted

From the comments, the MWE is

\documentclass{book}
\usepackage[cross-reference]{hyperref}
\begin{document}
\end{document} 

As observed by others, cross-reference is not a valid option for hyperref, so the error message is entirely correct.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.