Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Does anyone know why the bibliography appears as in the picture when using Hoefler Text (and how to fix it)?

enter image description here

Here's a minimal working example:

\documentclass[11pt, a4paper]{article}
\usepackage{fontspec}
\setmainfont[Mapping=tex-text]{Hoefler Text}

\begin{document}    
\section{References}
\end{document}

Addendum: Let's ask this differently. Suppose I wanted to specify which font XeLaTeX should use for bold faces. Which command should I use?

share|improve this question
1  
What class are you using? And how do you produce the bibliography? –  egreg May 23 '11 at 23:31
5  
This is the Engraved Capitals set. Try removing the Alternates. –  Emre May 23 '11 at 23:38
2  
A note: you should use 4\textsuperscript{th}, preferably with the xltxtra or realscripts package loaded. –  Andrey Vihrov May 24 '11 at 8:03
    
Uh, how do I remove the alternates? –  Hugo S Ferreira May 31 '11 at 23:45
    
I really need a code answer to this one :-) –  Hugo S Ferreira Jul 2 '11 at 15:59

1 Answer 1

up vote 5 down vote accepted
+50

The font setting should be:

\setmainfont[Mapping=tex-text, ItalicFeatures={Alternate=0,
            Contextuals={NoLineFinal,NoLineInitial}}, 
            Ligatures={Common,Historic},Alternate=1,
            BoldFont=Hoefler Text Black]{Hoefler Text}

then I have no problem with xelatex.

the fonts in the pdf:

voss@shania:~/Documents> pdffonts latex6.pdf
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
DUZIVX+HoeflerText-Black             CID TrueType      yes yes yes      5  0
VLJLSS+HoeflerText-Regular           CID TrueType      yes yes yes      7  0
share|improve this answer
    
I updated the minimal working example, and it still uses the engraved fonts :-( –  Hugo S Ferreira Jul 2 '11 at 16:25
    
For some reason, XeLaTeX uses the first variant it finds for bold. If I disable Engraved in my system, it will use Fleurons, and so on... –  Hugo S Ferreira Jul 2 '11 at 16:29
    
Also no problem. I've posted the file list –  Herbert Jul 2 '11 at 16:29
    
Suppose I wanted to specify which font XeLaTeX should use for bold faces. Which command should I use? –  Hugo S Ferreira Jul 2 '11 at 16:29
2  
\setmainfont[Mapping=tex-text, BoldFont=Hoefler Text Black]{Hoefler Text} –  Herbert Jul 2 '11 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.