Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have TeXlive 2014 recently installed on a new machine. Everything seems to be working smoothly EXCEPT for PSTricks. I am testing with minimal code such as

\documentclass{article}

\usepackage{pstricks}
\usepackage{pst-xkey}
\usepackage{pst-jtree}
\usepackage{multido}  

\begin{document}

-- N   -- \rnode{2}{OP} -  C -- \ldots \rnode{1}{t} ---

\psset{linestyle=dashed,linearc=2pt,nodesepA=.1, nodesepB=.3} 
    \ncbar[angle=-90]{<-}{2}{1} 

\end{document}

This compiles cleanly on my old machine, running TeXlive 2008. On the new machine, I get the following error when compiling in TeXShop with TeX + DVI:

Error: /undefined in NodeScale
Operand stack:
   --nostringval--   false   N@2   16   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1900   1   3   %oparray_pop   1899   1   3   %oparray_pop   1883   1   3   %oparray_pop   1771   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1168/1684(ro)(G)--   --dict:0/20(G)--   --dict:116/200(L)--   --dict:183/300(L)--   --dict:117/200(L)--   --dict:48/400(L)--
Current allocation mode is local
Last OS error: Invalid argument
Current file position is 128730
GPL Ghostscript 9.10: Unrecoverable error, exit code 1
### FAILED to generate /tmp/altpdflatex.5908-1406243855/mwe.pdf ()

I take it the issue with the creation of the PS file itself, since it can't be converted to PDF by Acrobat, either. What am I doing wrong?

share|improve this question
    
This runs without problem on my machine (running TeX Live 2014) producing this output. –  Werner Jul 24 at 23:29
    
Yes, that's what I see on my older machine. Your comment suggests it's not the distribution (and of course it's not, the whole world would be screaming if PSTricks quit working!) but I'm not sure what else could be involved. –  Amy Rose Jul 24 at 23:31
    
Are you running it using the compile sequence LaTeX > dvips (> ps2pdf)? –  Werner Jul 24 at 23:59
    
Yes, through dvips. That is the way that works on the old machine. –  Amy Rose Jul 25 at 0:12
    
Your files pst-node.tex and pst-node.pro are not up-to-date. Put \listfiles as first line into your document and post the file list which is at the end of your log file –  Herbert Jul 25 at 6:31

2 Answers 2

up vote 1 down vote accepted

With an up-to-date TL 2014 you should get this file list:

*File List*
article.cls 2007/10/19 v1.4h Standard LaTeX document class
size10.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
pst-node.sty 2010/04/22 package wrapper for pst-node.tex
pstricks.sty 2013/12/12 v0.60 LaTeX wrapper for `PSTricks' (RN,HV)
ifpdf.sty 2011/01/30 v2.3 Provides the ifpdf switch (HO)
pstricks.tex 2014/05/19 v2.54a `PSTricks' (tvz,hv)
pst-xkey.tex 2005/11/25 v1.6 PSTricks specialization of xkeyval (HA)
xkeyval.sty 2014/05/25 v2.7 package option processing (HA)
xkeyval.tex 2014/05/25 v2.7 key=value parser (HA)
pst-fp.tex 2014/05/19 v2.54a `PST-fp' (hv)
pstricks.pro 2012/10/16 v. 1.15, PostScript prologue file (hv)
pst-algparser.pro 2011/10/31 v. 0.04, PostScript prologue file (hv)
pst-tools.pro 2012/01/01 v. 0.02, PostScript prologue file (hv)
pst-dots.pro 2006/12/19 v. 2.00, PostScript prologue file (hv)
xcolor.sty 2007/01/21 v2.11 LaTeX color extensions (UK)
color.cfg 2007/01/18 v1.5 color configuration of teTeX/TeXLive
xetex.def 2014/04/28 v4.01 LaTeX color/graphics driver for XeTeX (RRM/JK)
pst-node.tex 2014/03/25 1.33 `pst-node' (tvz,hv)

I used this example and run it with xelatex:

\listfiles
\documentclass{article}
\usepackage{pst-node}
\begin{document}

-- N   -- \rnode{2}{OP} -  C -- \ldots \rnode{1}{t} ---
\ncbar[linestyle=dashed,linearc=2pt,nodesepA=.1, nodesepB=.3,angle=-90]{<-}{2}{1} 

\end{document}
share|improve this answer
    
Thanks, Herbert, updating pst-node solved the problem. The version I had been using was dated 2000. I wonder why this didn't update with TeXlive 2014?! –  Amy Rose Jul 25 at 16:04
    
No. TL 2014 had an up-to-date version. There must be something different in your distribution. However, it is working now and that#S fine :-) –  Herbert Jul 25 at 17:22

The problem is only to put everything in a pspicture (compiles with pdflatex):

\documentclass[pdf]{article}

\usepackage{pstricks}
\usepackage{pst-xkey}
\usepackage{pst-jtree}
\usepackage{multido}

\begin{document}
\begin{pspicture}
-- N   -- \rnode{2}{OP} -  C -- \ldots \rnode{1}{t} ---
\psset{linestyle=dashed,linearc=2pt,nodesepA=.1, nodesepB=.3}
    \ncbar[angle=-90]{<-}{2}{1}
\end{pspicture}

\end{document} 

enter image description here

share|improve this answer
    
This compiled in pdftex (after I noticed that you'd added [pdf] to the document class) but did not print the figure correctly. It only printed the long dash, N, longdash. Error "Non-PDF special ignored!" 4x. –  Amy Rose Jul 25 at 0:01
    
What are you supposed to obtain? Do you mean you didn't obtain the same figure as in my answer? I also can compile via LaTeX->dvi->ps and get exactly the same result. No error message. –  Bernard Jul 25 at 0:41
    
May be try updating GhostScript (last version is 9.14). –  Bernard Jul 25 at 0:43
    
the environment pspicture is not needed. –  Herbert Jul 25 at 6:27
    
@Herbert: There's an error message with the pdf option if I don't use a pspicture environment. It seems to be a problem with auto-pst-pdf, as the filename-autopp-log, after a torrent of insults, ends with `(job aborted, no legal \end found). –  Bernard Jul 25 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.