Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

i have this code taken from another question trying to produce a tree:

\documentclass{article}
\usepackage{tikz-qtree}
\begin{document}
\tikzset{edge from parent/.style=
{draw, edge from parent path={(\tikzparentnode.south)
-- +(0,-8pt)
-| (\tikzchildnode)}}}
\begin{tikzpicture}
\matrix
{
\node{\Tree
    [.Class  \edge[color=white]; 
    [.Order  \edge[color=white];
    [.Family \edge[color=white]; 
    [.Genus ]]]]};
&
\node{\Tree 
 [.{$\gamma$-proteobacteria} 
    [.Alteromonadales 
        [.Alteromonadaceae  {Glaciecola}  Alteromonas Agarivorans ] ]
    [.Vibrionales [.Vibrionacae Vibrio ]]]};\\
};           
\end{tikzpicture}

\end{document}

but when compiling using TeXworks in MiKTeX 2.9 i always get the same error:

This is pdfTeX, Version 3.1415926-1.40.11 (MiKTeX 2.9)
entering extended mode
(C:/Users/nagi/Desktop/these/myLaTeX/these.tex
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic, 
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2009-06-19, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, lao, latin, lat
vian, lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerm
an, ngerman-x-2009-06-19, nynorsk, oriya, panjabi, pinyin, polish, portuguese, 
romanian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swis
sgerman, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, u
senglishmax, welsh, loaded.
("C:\Program Files\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
("C:\Program Files\MiKTeX 2.9\tex\latex\base\size10.clo"))
("C:\Program Files\MiKTeX 2.9\tex\latex\tikz-qtree\tikz-qtree.sty"
======================================================================
pdflatex.EXE: Cannot start MiKTeX package manager.
pdflatex.EXE: Data: The class is not configured to support Elevated activation.

======================================================================


! LaTeX Error: File `tikz.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name: 

can you help me solve this issue, i really need to draw some trees in my thesis...
thank you.

EDIT:
as requested by Alan Munn, i tried to install pgf from the package manager, and received this error at the end of the download process:

MiKTeX Problem Report Message: The operation could not be completed because the following file failed verification: C:\Users\nagi\AppData\Local\Temp\mik2E71.tmp

i tried installing pgf again after some time, but with the same result (error).

share|improve this question

closed as too localized by Martin Scharrer Apr 16 '12 at 16:28

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
This really seems to have nothing to do with tikz-qtree but everything to do with MikTeX. Can you use the MikTeX package manager manually to install tikz and tikz-qtree? See this question: How can I manually install a package on MiKTeX (Windows) –  Alan Munn May 29 '11 at 23:39
    
@Alan: i used the package manager and installed tikz-qtree but couldn't find tikz anywhere... –  astazed May 29 '11 at 23:43
    
@Nagi Try installing pgf instead. –  Alan Munn May 29 '11 at 23:46
    
@Alan: got the same error twice when trying to install pgf:"MiKTeX Problem Report Message: The operation could not be completed because the following file failed verification: C:\Users\nagi\AppData\Local\Temp\mik2E71.tmp" –  astazed May 29 '11 at 23:55
1  
It looks as if the pgf-package is corrupted. There already exist a bug report and it will hopefuly be corrected soon. You can try to find an "outdated" repository which still has an older version and use this to install pgf miktex.org/pkg/repositories. –  Ulrike Fischer May 30 '11 at 8:00
show 7 more comments

1 Answer

up vote 0 down vote accepted

Thank you all! With your feedback I was able get this example to run. I googled and installed manually the packages pgf and ms using the package manager. Hope MiKTeX will fix their repositories soon...

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.