Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I include graphics in my document, the colors are always converted to grayscale, which is very unfortunate as I depend on the colors in the images.

I use LaTeX => PS => PDF for creating my document. Here is a MWE:

\documentclass[11pt,oneside,a4paper]{scrartcl}
\usepackage{graphicx}
\DeclareGraphicsExtensions{.eps,.png,.pdf}
\graphicspath{{E:/.../images/}}

\begin{document}

\begin{figure}[ht!]
    \centering
    \includegraphics[bb=0 0 966 503,scale=0.4]{images/highlight}
    \caption{Hervorgehobenes Bauteil}
\end{figure}

\end{document}

The following image is the result.

enter image description here

share|improve this question
1  
Works for me with latex + dvipdfm and with pdflatex (after removing the bb option). I have no idea with editor/IDE you use and which commands it executes for LaTeX => PS => PDF. You could try to remove the PNG to EPS manually or simply use pdflatex (most likely called LaTeX => PDF for you). –  Martin Scharrer May 31 '11 at 8:15
add comment

1 Answer

up vote 5 down vote accepted

I recommend using pdfLaTeX, which directly supports PNG image format. This means directly compiling to PDF, instead of using DVI and PS as intermediate format.

If you also need (E)PS images, you can use the epstopdf LaTeX package or the program with the same name and include them as PDF files.

share|improve this answer
    
That worked nicely. I just included epstopdf, deleted the bb-attributes and everything works. Thanks a bunch! –  Florian Peschka May 31 '11 at 8:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.