Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using miktex in win 7

my MWE is

\documentclass[12pt,a4paper,fleqn]{book}
%
\usepackage{subfiles}
\usepackage{thesis_style}

\title{hfvj}
\author{fgikf}
\date{}

\begin{document}

\begin{landscape}
\begin{table}[htbp]
\scriptsize\addtolength{\tabcolsep}{-2pt}
\centering
\begin{tabular}{lrrrrrrrrrrrrrrrrrrrrrr}
Longitude & \multicolumn{2}{|c|}{114.25} & \multicolumn{2}{|c|}{-155.79} & \multicolumn{2}{|c|}{-96.58} & \multicolumn{2}{|c|}{-8.02} & \multicolumn{2}{|c|}{101.27} & \multicolumn{2}{|c|}{37.00} & \multicolumn{2}{|c|}{-79.82} & \multicolumn{2}{|c|}{-100.37} & \multicolumn{2}{|c|}{-117.85} & \multicolumn{2}{|c|}{102.98} & \multicolumn{2}{|c}{-110.33}  \\
Latitude & \multicolumn{2}{|c|}{37.87} & \multicolumn{2}{|c|}{20.13} & \multicolumn{2}{|c|}{39.08} & \multicolumn{2}{|c|}{38.53} & \multicolumn{2}{|c|}{21.93} & \multicolumn{2}{|c|}{-4.00} & \multicolumn{2}{|c|}{39.08} & \multicolumn{2}{|c|}{41.86} &         \multicolumn{2}{|c|}{33.66} & \multicolumn{2}{|c|}{38.57} & \multicolumn{2}{|c}{31.48}  \\
\hline
Depth (cm) & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min   & Max   & Min \\
\hline
5     &       &       & 9.07  & -9.46 &       &       & 3.80  & 0.50  &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
10    &  –5.4   &  –10.6   & 9.72  & -11.33 & -1.80 & -1.90 &       &       & -3.00 & -5.00 &       &       &       &       &       &       &       &       &       &       & -2.00 & -5.00 \\
15    &       &       & 11.03 & -11.22 &       &       & 3.50  & 2.20  &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
20    &  –3.6   &  –10.3   & 7.52  & -11.35 & -3.00 & -3.80 &       &       & -5.50 & -6.40 &       &       &       &       &       &       &       &       & 7.00  & 2.00  & -8.50 & -9.00 \\
25    &       &       &       &       &       &       & -0.50 & -2.00 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
30    &  –7.3   &  –10.6   & 7.79  & -10.38 & -2.60 & -3.90 &       &       &       &       &       &       & -5.80 & -10.90 &       &       &       &       & 7.00  & 3.00  &       &  \\
35    &       &       &       &       &       &       & -1.00 & -2.50 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
40    &       &       & 6.69  & -8.37 & -2.40 & -5.80 &       &       &       &       & -3.50 & -4.50 &       &       &       &       &       &       &       &       &       &  \\
45    &       &       &       &       &       &       & -2.50 & -5.80 & -5.00 & -5.80 &       &       &       &       &       &       &       &       &       &       &       &  \\
50    &  –7.1   &  –10.4   & 3.98  & -5.95 & -6.50 & -6.90 &       &       &       &       &       &       &       &       & -11.00 & -12.00 &       &       & 4.00  & 1.00  &       &  \\
55    &       &       &       &       &       &       & -3.50 & -5.80 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
60    &       &       &       &       &       &       &       &       & -6.00 & -7.00 &       &       &       &       &       &       &       &       &       &       & -9.00 & -15.00 \\
65    &       &       &       &       &       &       & -3.80 & -5.80 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
70    &  –7.4   &  –9.8   & 3.15  & -4.93 & -6.80 &       &       &       &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
75    &       &       &       &       &       &       & -5.80 & -6.10 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
80    &       &       &       &       &       &       &       &       & -6.80 & -7.80 &       &       &       &       &       &       &       &       &       &       &       &  \\
85    &       &       &       &       &       &       & -5.80 & -5.90 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
90    &  –6.4   &  –7.7   & 2.63  & -6.57 & -6.00 & -6.50 &       &       &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
95    &       &       &       &       &       &       & -4.50 & -4.50 &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
100   &       &       &       &       & -6.40 & -6.60 &       &       & -7.00 & -7.50 &       &       &       &       & -10.50 & -12.50 & -0.50 & -3.00 & 1.00  & -5.00 & -13.00 & -13.50 \\
110   &  –6.9   &  –8.2   &       &       & -5.80 & -8.20 &       &       &       &       &       &       &       &       &       &       &       &       &       &       &       &  \\
120   &       &       &       &       &       &       &       &       & -6.20 & -7.50 &       &       &       &       &       &       &       &       &       &       &       &  \\
150   &       &       &       &       &       &       &       &       & -7.00 & -7.80 &       &       &       &       & -10.00 & -11.50 &       &       &       &       & -13.00 & -13.00 \\
200   &       &       &       &       &       &       &       &       &       &       &       &       &       &       & -10.50 & -12.50 &       &       &       &       &       &  \\
300   &       &       &       &       &       &       &       &       &       &       &       &       &       &       & -14.00 & -11.00 &       &       &       &       &       &  \\
\hline
\end{tabular}%
\caption{reghg}\label{ewt}
\end{table} 

\end{landscape}

\end{document}

The .sty file is

\ProvidesPackage{thesis_style}
%
%%% PAGE DIMENSIONS AND SETTINGS
\usepackage{geometry} % to change the page dimensions
\geometry{a4paper} % or letterpaper (US) or a5paper or....
%\geometry{margin=1in} % for example, change the margins to 2 inches all round
\geometry{top=1.0in, bottom=1.0in, left=1in, right=1in}
% \geometry{landscape} % set up the page for landscape
%%spacing between lines
\usepackage{setspace}
\doublespacing
% Activate to begin paragraphs with an empty line rather than an     indent
%\usepackage[parfill]{parskip} 
%
%%%%
%%%%GRAPHICS, FLOATS, SYMBOLS AND MATHS
% support the \includegraphics command and options
\usepackage{graphicx} 
\usepackage{booktabs} % for much better looking tables
\usepackage{floatrow}%for side captions
% for rotating floats
\usepackage{lscape}
%for subfigures and tables
\usepackage[font=small,labelfont=bf]{caption}
\usepackage[font=footnotesize]{subfig}
%for long tables
\usepackage{longtable}
\usepackage{amsmath,amssymb}
%\usepackage[osf,sc]{mathpazo} %for upright math
\usepackage{eulervm}
\usepackage{gensymb}
\usepackage{wasysym} %for per mil sign
\usepackage{array} % for better arrays (eg matrices) in maths
\usepackage{paralist} % very flexible & customisable lists (eg. enumerate/itemize, etc.)
\usepackage{verbatim} % adds environment for commenting out blocks of text & for better verbatim
\usepackage{subfig} % make it possible to include more than one captioned figure/table in a single float
\usepackage[version=3]{mhchem} % for upright CO2 etc
\usepackage{wrapfig}%text wrapped figures
%%%%%
%%%%%FONT SETTINGS
%changing the default font
\renewcommand*{\familydefault}{\rmdefault}
\renewcommand*\rmdefault{ppl}
%%%to modify chapter heading look and size
\usepackage{calligra}%For cursive font
\usepackage[T1]{fontenc}
\usepackage{titlesec, blindtext, color}
\definecolor{brown}{rgb}{0.5, 0.2, 0.0}
\definecolor{cornellred}{rgb}{0.7, 0.11, 0.11}
\definecolor{brown_w}{rgb}{0.65, 0.16, 0.16}
%\titleformat{\chapter}[hang]{\Large\bfseries}{\thechapter\hsp\textcolor{gray75}{|}\hsp}{0pt}{\Large\bfseries}
\titleformat{\chapter}[hang]{\normalfont\Large\bfseries}{\chaptertitlename\         \thechapter:}{1em}{} 
\titlespacing*{\chapter}{0pt}{0pt}{5pt}
\titlespacing*{\section}{0pt}{0pt}{5pt}
\usepackage{atbegshi,etoolbox}
%
%% Get underlining for headings right
\usepackage[normalem]{ulem}
%%% HEADERS & FOOTERS
\usepackage{fancyhdr} % This should be set AFTER setting up the page geometry
\setlength{\headheight}{50pt} 
\pagestyle{fancy} % options: empty , plain , fancy
\fancyhead{}
\renewcommand{\headrulewidth}{1pt} % customise the layout...
\renewcommand{\footrulewidth}{1pt}
\lhead{\slshape\nouppercase{\leftmark}}\chead{}\rhead{}
\lfoot{}\cfoot{}\rfoot{\thepage}
%
\def\bibfont{\footnotesize} %to decrease font size of the bibliography
%%%
%%% ToC (table of contents) APPEARANCE
\usepackage[nottoc,notlof,notlot]{tocbibind} % Put the bibliography in the ToC
%%%%
\setcounter{tocdepth}{1}
\renewcommand{\bibname}{References}
\usepackage[colon,authoryear]{natbib}
%
%mytilde
\newcommand{\mytilde}{\raise.17ex\hbox{$\scriptstyle\mathtt{\sim}$}} %around tilde

sorry for such a long file but this is a multi file project with single style.

problem

as you can see I am getting the red boxed columns weird but others look fine ...

share|improve this question
    
A tip: If you indent lines by 4 spaces or enclose words in backticks `, they'll be marked as code, as can be seen in my edit. You can also highlight the code and click the "code" button (with "{}" on it). –  Christian Hupfer Aug 10 at 9:44
    
And the problem is? –  egreg Aug 10 at 9:45
    
Could you show the output in a picture, OP? I'm getting exactly the table as expected. –  1010011010 Aug 10 at 9:47
    
Please check now –  ankhi Aug 10 at 9:58
2  
Just add the instruction \usepackage[utf8]{inputenc} to the style file. –  Mico Aug 10 at 10:04

1 Answer 1

up vote 3 down vote accepted

It looks like some of your input isn't encoded in ("pure") ASCII. If you add the instruction

\usepackage[utf8]{inputenc}

to the file thesis_style.sty, things appear to work out alright -- at least as far as the "weird characters" in some of the columns of the table are concerned.

By the way, the "weird characters" in the case at hand are fourteen [14!] instances of the Unicode (non-ASCII) character . With utf8 input encoding enabled, these characters produce typographically correct "minus signs" rather than just simple (short) dashes. You could use an editor to replace the fourteen [14!] instances of (Unicode minus) with - (simple dash). That, or replace all instance of the simple dash character in the numerical part of the table with (Unicode minus)... If the problems with "weird characters" persist, you should probably spend some time figuring out what's causing parts of the input to be encoded in unexpected ways. Did you maybe copy-and-paste some (but not all) of the tabular material from another source?

If I make a separate comment: The file thesis_style.sty currently has the instruction

\renewcommand*\rmdefault{ppl}

While this instruction serves to set the main text font to Palatino, it doesn't affect any material typeset in math mode. You should really replace this instruction with

\usepackage{mathpazo}

or -- assuming you have a reasonably up-to-date TeX distribution -- with

\usepackage{newpxtext,newpxmath}
share|improve this answer
    
Thanks for your suggestions ... this is my first style file ... all suggestions to improve it are most welcome .... \usepackage{newpxtext,newpxmath} is not working on miktex –  ankhi Aug 10 at 10:24
1  
@ankhi - You mention that you use MikTeX. Have you maybe disabled (or "not enabled"...) the MikTeX feature that accesses a MikTeX file depository to download and install missing packages on the fly? –  Mico Aug 10 at 10:30
    
I dont know how to do that .... my latex is pretty basic .... I just installed miktex but dunno how to enable or disable stuff –  ankhi Aug 10 at 10:31
1  
@ankhi 'newpxtext' and 'newpxmath'' is part of the package 'newpx'. Maybe you have to install 'newpx' first in MikTeX. In my portable version of MikTeX, '\usepackage{newpxtext,newpxmath}' did not work. The packages was not automatically downloaded, I just got the usual error message and prompt to enter a new file name. –  Sveinung Aug 10 at 10:48
1  
@ankhi -- Looks like several font-related files are missing. Since I'm not a (regular) MikTeX user I'm afraid I don't know how to suggest a further remedy related to the newpx packages. Does \usepackage{mathpazo} (along with a deletion of the line \usepackage{eulervm} in the style file) help? –  Mico Aug 10 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.