Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a file that defines a bunch of commands for various variables that I use in other documents. Here's a small example of what it contains:

\newcommand{\varElevation}{\ensuremath{\alpha_{el}}}
\newcommand{\varAzimuth}{\ensuremath{\alpha_{az}}}
\newcommand{\varRoll}{\ensuremath{\phi}}
\newcommand{\varPitch}{\ensuremath{\theta}}
\newcommand{\varYaw}{\ensuremath{\psi}}

I use the input{...} command to insert the above file into the preambles of the documents that use those variables (thus making it very easy to change the symbols I use for the variables across multiple documents). Although the documents build correctly, TexMakerX highlights all calls to those custom commands as "unrecognized commands." Is there a way to get TexMakerX to parse the input file as well so that the syntax highlighting is correct?

share|improve this question
    
Did my answer help you? If yes it would be nice to vote if no pleas tell me why it didn’t help. –  Tobi Jun 10 '11 at 8:58
    
@Tobi: Thanks for the answer. I was trying out a few different editors looking for a feature that I wanted (preserved indentation for word-wrapped lines) and was annoyed at this highlighting issue with TexMakerX (which has now been renamed to TeXstudio). Ultimately, I settled on building my own version of TeXnicCenter from source since the indentation feature was implemented soon after the latest alpha release. Your answer does seem like a workaround, but it also seems like the only way to address the problem since no one else has chimed in. BTW, the renaming to TeXstudio broke your links. –  Brandon Jun 19 '11 at 7:22
    
OK. Thanks for telling me the broken links. I fixed it. –  Tobi Jun 19 '11 at 10:00
add comment

1 Answer

up vote 3 down vote accepted

It is possible to create an own CWL-File but this seems to be a workauround in your case. Unfortunatly I couldn’t finde out where to put these files, but I’m still searching …

Update

The files should be in the config directory which is ~/.config/benibela or c:\Documents and Settings/User/AppData/Roaming/benibela. See 1.4 Configuring the autocompletion in the manual. (Mac see below at Update 3)

Update 2

I tried to make an example an it didn’t work. It seems that the given path is wrong, so I ask the developer of tmx for help and give the next update with the (hopefully) working path an an example.

Update 3

Now I got an answer from the developer and at the moment the configfiles on a Mac are only searched in the .app-Folder: /Contents/Resources/completion

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.