Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using Palatino (\usepackage[sc]{mathpazo}) as the main font for my thesis, and it occurred to me that italic (and possibly also bold) body texts are somewhat smaller than the '\normalsize\normalfont' texts.

Here is an image to illustrate the phenomenon:

image illustrating the phenomenon

Is this default Palatino behavior? Is there a way to particularly change the size of the italic and bold parts of the body text?

share|improve this question
    
that is the default behaviour –  Herbert Jun 1 '11 at 8:00
add comment

2 Answers

up vote 5 down vote accepted

There's probably something in your preamble messing things, because, by default, the italics of Palatino match the height of the roman:

result of the code below

Here's the code I used:

\documentclass{article}
\usepackage[sc]{mathpazo}
\parindent=0em
\begin{document}
\textit{is expected to integrate with current}\par
xt three propositions (\textit{A softw}\par
\textit{software architecture quality} \textbf{(P2)},\par
\textbf{(P4))} are also confirmed: en\par
\end{document}
share|improve this answer
    
@Philippe Actually the height of a capital upright B is 6.98pt, it's 6.96pt for the italic B, it's 6.86pt for the boldface B. The x-height is 4.69pt (roman), 4.82pt (italic) and 4.71pt (bold). And the italic lowercase letters are noticeably higher than the upright ones. The global font size shouldn't make any difference, because these fonts are scaled. –  egreg Jun 1 '11 at 8:50
    
@Philippe The figures are slightly different when a T1 encoded font is used: 6.93pt, 6.935pt, 6.705 for the B; the x-heights don't change. –  egreg Jun 1 '11 at 9:11
1  
@egreg: You can't judge this kind of things with individual letter height (and the measures should be made in a font editing software like fontforge, sometimes TeX metrics are different). You must absolutely print a text sample with mixed words in roman, bold and italic and use your eye as sole judge. Doing this, the thing which is really amiss is all caps bold text among all caps roman text. Generally, bold must be slightly taller than roman to seem the same height, but it's font dependent. Here, of course, dbaw's problem is not something as subtle as that. –  Philippe Goutet Jun 1 '11 at 9:14
    
@Philippe: the printout confirms the figures. The boldface font is slightly smaller, but one should note that it's not in the original design by Zapf. –  egreg Jun 1 '11 at 9:27
2  
I get the same output as Philippe which differs from the image of the question. Most notably the brace before the A shows that different sizes are used. I think a complete example and the log-file of the pdflatex run is necessary. –  Ulrike Fischer Jun 1 '11 at 10:01
show 4 more comments

I was having a similar (though not same) problem with mathpazo and \textit, so I'd just like to jot down my debug notes:

My problem was that what I expected to be italic, turned out to be bold - and sans serif (which I definitely didn't want)!

  • First I tried inspecting \textit using \show and \pshow - went a bit tedious, didn't show much
  • Then I realized that my problem occurs in \paragraph*{\textit{Text ... }} - hence it could be the \paragraph* that is the problem
  • I try to inspect it with \tracingall - but since "there’s no “off” command for \tracingall", I use as recommended \usepackage{trace} and place \traceon/\traceoff around the offending line
  • Search for sf (for the sans serif) in the resulting .log, find this:
    \sectfont ->\normalcolor \sffamily \bfseries

So, I starting tracing back what could have set the \sectfont to \sffamily, but since there's plenty of packages to go through, instead of finding which is the offending one, I simply "overloaded" (redefined) the \sectfont command before the offending line comes in:

....
% redefine sectfont to avoid setting sans-serif \sffamily
\def\sectfont{\normalcolor\bfseries}

\paragraph*{$\bullet$ "\textit{Text ... 
....

... and this got all working (at least for my problem).

Hope this helps someone,
Cheers!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.