Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I put in the preamble of my document:

\usepackage[brazil]{babel}
\usepackage[latin1]{inputenc}

When I compile as a PDF, I receive the output:

"No hyphenation patterns were loaded for(babel)
the language 'Portuguese'(babel)
I will use the patterns loaded for \language=0 instead"

What am I doing wrong?

My main LaTeX editor is Kile.

share|improve this question

3 Answers 3

This problem usually belongs to MiKTeX users up to version 2.8. Upgrade to version 2.9 or enable the language in the MiKTeX setting program.

Also who has TeX Live/Ubuntu can have this problem and the solution is to install with Synaptic the package texlive-lang-portuguese.

share|improve this answer
    
While updating certainly is a good idea, I would think it is related to the language not being activated in the settings. Go to Settings->Languages and activate portuguese. –  doncherry Jun 2 '11 at 0:27
    
MikTeX 2.9 is only for Windows. I use Ubuntu. –  Dante Cardoso Pinto de Almeida Jun 2 '11 at 3:35
    
@Dante It's important to specify system and TeX distribution in cases like yours. I've updated my answer. –  egreg Jun 2 '11 at 9:10

You are not doing anything wrong. The only thing is that hyphenation for Portuguese appears not to be installed in your distribution. In the babel CTAN page you can find all dictionaries.

You should download portuges.ins and portuges.dtx. Run latex portuges.ins to create the Portuguese dictionary.

share|improve this answer
    
OK, but... how do I run the file? –  Dante Cardoso Pinto de Almeida Jun 2 '11 at 4:38
    
portuges.dtx is the source for the language definition file that babel loads. that is what complains about the lack of hyphenation tables; loading the tex portuguese language package loads the hyphenation tables (and rebuilds the formats as necessary); this has already been recommended –  wasteofspace Jun 2 '11 at 11:04

It's a quite common problem.

You could not have the right packages installed in your system. Try installing texlive-lang-portuguese

Should solve it!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.