Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This seems like a rudimentary question but I haven't been able to find a clear answer. The cultural context in question is American English.

When putting citations in footnotes in biblatex (I'm using biblatex-chicago), the rule I've been following is to put the citation commands where they would go if the citation were parenthetical: after the end quote and before the final punctuation mark. The end result, however, has the punctuation mark after the quote, e.g. "this is my quote".1 The correct punctuation should be "this is my quote."1 How can this be accomplished automatically?

Here is an example document:

\documentclass[]{article} 
\usepackage[]{setspace} 
\usepackage[utf8]{inputenc} 
\usepackage[american]{babel} 
\usepackage[]{csquotes} 
\usepackage[backend=biber,bibencoding=utf8]{biblatex}
\usepackage[]{hyperref} 
\bibliography{mybib} 
\begin{document} ``This is a quote''\autocite[1]{mysource}. 
\end{document}
share|improve this question
2  
I may have misunderstood your question, in which case my answer may not be helpful. Can you add snippet of code (or better yet, a minimal document) that shows what you are doing. –  Alan Munn Jun 2 '11 at 21:48
    
Hi @AlanMunn, here's a minimal document: \documentclass[]{article} \usepackage[]{setspace} \usepackage[utf8]{inputenc} \usepackage[american]{babel} \usepackage[]{csquotes} \usepackage[backend=biber,bibencoding=utf8]{biblatex} \usepackage[]{hyperref} \bibliography{mybib} \begin{document} ``This is a quote''\autocite[1]{mysource}. \end{document} When the citation style is set to, say, verbose, the . comes after the '' and before the footnote mark. The American style requires the . to come before the ''. –  Jonathan Jun 3 '11 at 14:52
    
I've updated my answer to actually answer your question. –  Alan Munn Jun 3 '11 at 17:50

1 Answer 1

up vote 11 down vote accepted

To a large extent, you can get American punctuation patterns automatically with biblatex by loading babel with the [american] option.

For your bibliography items themselves

If you load the babel package with the option [american], biblatex will put the punctuation inside the quotation marks automatically. This is explained in section 3.91 of the biblatex manual.

For in text quotations

The best way to do this automatically is to use the \textquote command of the csquotes package. You need to change the default formatting for the citation part of the quote, and you need to redefine the \mktextquote command. This is explained in section 9.2 of the csquotes manual.

Here is an example document. Notice that the quotation marks in the text quotation and in the bibliography item are in the correct place for American standards. The example works the same way with the biblatex-chicago package loaded.

\documentclass[12pt]{article}
\usepackage[citestyle=verbose]{biblatex}
%\usepackage{biblatex-chicago} % or load this instead
\usepackage[american]{babel}
\usepackage{csquotes}
\renewcommand{\mktextquote}[6]{#1#2#4#5#3#6}
\renewcommand*{\mkcitation}{}
\bibliography{biblatex-examples}
\usepackage{lipsum}
\begin{document}

Here is a quotation \textquote[\autocite{shore}]{Some text}.

\end{document}

output of code

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.