Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want the footnote mark to be superscripted in the text body (e.g. Footnote mark²), but normalsize in the foot, to be shown like:

________________
2. Some footnote text

Also, it would be nice if the mark appeared hanging in the left margin, like

   ________________
2. Some footnote text

(That is recommended by Bringhurst in his Elements of Typographic Style)

share|improve this question
add comment

3 Answers

up vote 11 down vote accepted

Use the scrextend package (part of KOMA-script) to customize footnotes. See section 3.14 of the documentation of KOMA-script for details about the \deffootnote macro.

\documentclass{article}

\usepackage{scrextend}
\deffootnote{0em}{1.6em}{\thefootnotemark.\enskip}

\usepackage[english]{babel}
\usepackage{blindtext}

\begin{document}

\blindtext\footnote{\blindtext}

\end{document}
share|improve this answer
    
simple and perfect! Thanks @lockstep –  henrique Jun 4 '11 at 0:31
add comment

This is a TeX approach, with doesn't need a package. I use it always. Maybe the code can be improved:

\documentclass{article}

\makeatletter
\newlength{\fnBreite}
\renewcommand{\@makefntext}[1]{%
  \settowidth{\fnBreite}{\footnotesize\@thefnmark.i}
  \protect\footnotesize\upshape%
  \setlength{\@tempdima}{\columnwidth}\addtolength{\@tempdima}{-\fnBreite}%
  \makebox[\fnBreite][l]{\@thefnmark.\phantom{}}%
  \parbox[t]{\@tempdima}{\everypar{\hspace*{1em}}\hspace*{-1em}\upshape#1}}
\makeatother

\usepackage[english]{babel}
\usepackage{blindtext}

\begin{document}

\blindtext\footnote{\blindtext}

\end{document}
share|improve this answer
2  
This works very nicely, with one problem: very long footnotes no longer break across pages, even when \footins is set manually to values small enough that footnotes should be forced to break. The fatal features seems to be the use of \parbox. Any thoughts on how to repair this feature? –  brannerchinese Aug 5 '12 at 15:21
add comment

I already had a solution for this problem, which I managed to come up by trial and error... I just didn't know if it was the best way to do it:

\makeatletter
  \renewcommand\@makefntext[1]{%
  \hspace*{-2em}
  \parindent 0em
  \noindent
  \hb@xt@ 1.8em{\hss %  There's the option of putting \hss before
  \@thefnmark. }%       or after \@thefnmark, aligning the footnote
  #1}%                  marks to the right or to the left, respectively
\makeatother

I tried to look at the definition of \deffootnote in scrextend.sty, but it seems to be much more complicated than that...

Anyway, the solution proposed by @lockstep is much simpler than this, although this one might be useful for class authors. Hope it helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.