Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My code goes like this:

\documentclass[12pt,letterpaper]{report}
\usepackage{blindtext}
\usepackage[utf8]{inputenc}
\usepackage[margin=1in]{geometry}
\usepackage{titlesec}


\titleformat{\chapter}[display]
{\filcenter\normalfont\bfseries}
{\MakeUppercase{\chaptertitlename}\ \thechapter}
{0pt}
{}
\titlespacing{\chapter}{0pt}{-24pt}{24pt}
\titleformat{\section}
{\normalfont\normalsize\bfseries}{\thesection}{12pt}{}

\usepackage{indentfirst}
\usepackage{parskip}
\setlength{\parindent}{.5in}

\usepackage{setspace}
\renewcommand{\baselinestretch}{1.75} 

\usepackage[square]{natbib}

\begin{document}
\include{CHAPTERS/Chapter1}


\bibliographystyle{plain}
\bibliography{2}
\end{document}

chapter 1.tex:

\chapter{Introduction}
\section{section}
The package offers two hooks, \\UrlLeft and \\UrlRight, that by default do
Appending material at left or right\cite{ruth}
nothing but can be redefined to typeset material at the left or right of text. The
material is typeset in the same fashion as the\cite{thomas} text. For example, spaces are ignored
unless one uses \ or specifies obeyspaces as an option. If \cite{jac}the commands are
redefined at the top level, they act on every \\url-like command. See Example 3-1-
34 on the next page for a possibility to restrict their scope.

and my .bib file code is this:

@Book{cetin,
ALTauthor = {Cetin Kurt and Jürgen Bittner},
ALTeditor = {•},
title = {"Sodium Hydroxide" Ullmann's Encyclopedia of Industrial Chemistry},
publisher = {Wiley-VCH Verlag GmbH \& Co.},
year = {2006},
OPTkey = {•},
OPTvolume = {•},
OPTnumber = {•},
OPTseries = {•},
OPTaddress = {•},
OPTedition = {7},
OPTmonth = {•},
OPTnote = {•},
OPTannote = {•}
}
@Book{thomas,
ALTauthor = {Thomas F. O'Brien and Tilak V. Bommaraju and Fumio Hine},
ALTeditor = {•},
title = {Handbook of Chlor-Alkali Technology Volume I: Fundamentals},
publisher = {Springer Science+Business Media Inc.},
year = {2005},
OPTkey = {•},
OPTvolume = {•},
OPTnumber = {•},
OPTseries = {•},
OPTaddress = {233 Spring Street, New York, NY 10013,
USA},
OPTedition = {•},
OPTmonth = {•},
OPTnote = {•},
OPTannote = {•}
}
@Book{ruth,
ALTauthor = {Ruth Stinger and Paul  Johnstonand},
ALTeditor = {•},
title = {Chlorine and the Environment-An Overview of the Chlorine Industry},
publisher = {Springer Science+Business Media Dordrecht},
year = {2001},
OPTkey = {•},
OPTvolume = {•},
OPTnumber = {•},
OPTseries = {•},
OPTaddress = {•},
OPTedition = {•},
OPTmonth = {•},
OPTnote = {•},
OPTannote = {•}
}
@Article{jac,
author = {Jacqueline Fauvarque},
title = {The Chlorine Industry},
journal = {Pure and Applied Chemistry},
year = {1996},
OPTkey = {•},
OPTvolume = {•},
OPTnumber = {•},
OPTpages = {•},
OPTmonth = {•},
OPTnote = {•},
OPTannote = {•}
}
@Misc{akzo:2009:Misc,
OPTkey = {•},
OPTauthor = {AkzoNobel},
OPTtitle = {•},
OPThowpublished = {https://www.akzonobel.com/ic/products/chlorine/},
OPTmonth = {•},
OPTyear = {•},
OPTnote = {•},
OPTannote = {•}
}

the unexpected output is this:

enter image description here

please help me...

share|improve this question
    
Could we have the real codes, not images, so we can test without having to re-type everything? –  Bernard Aug 30 at 8:06

1 Answer 1

up vote 4 down vote accepted

Remove the ALT prefixes from author and editor fields, i.e., change ALTauthor to author and ALTeditor to editor.

Do this only for fields whose values are not {•}, of course, or you'll get some bitter complaints from BibTeX...

By the way, I think the title of the cetin entry should start with

{``Sodium Hydroxide'' Ullmann's...

rather than with

{"Sodium Hydroxide" Ullmann's 

For sure, use whatever quotes are appropriate for the main language of your document -- just don't use "dumb quotes".

share|improve this answer
    
Wow! It solved the problem. Thank you so much. it was in TexMaker I just used the insert options in one of the menus. I don't know why they put those words in there. anyway thank you for your help. –  Ricardo Veloz Jr Aug 30 at 8:26
    
@RicardoVelozJr - I guess the template uses the ALT and OPT prefixes so that BibTeX won't choke on the non-ASCII character . Just remove the ALT and OPT prefixes once you've supplied the appropriate information. Incidentally, it's probably a good idea to remove all fields you don't use for a given entry. If nothing else, it'll reduce clutter. –  Mico Aug 30 at 8:30
    
I followed your advice sir on {``Sodium Hydroxide'' Ullmann's... and it really did improved. I just started LaTeX yesterday for my thesis thank you for being so considerate in answering my question. –  Ricardo Veloz Jr Aug 30 at 8:33
    
@RicardoVelozJr - No need to address Jabba the Hutt as "sir". :-) –  Mico Aug 30 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.