TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use the [typeset second] option in a beamer frame as specified by the Beamer User Guide. When I compile with that option, I receive the error Undefined control sequence \end{frame}

I tried compiling the sample from the guide and received the same error. This issue has been reported occasionally but I haven't found a solution. Full code listing (copied directly from the guide):

\setbeameroption{second mode text on second screen}
\begin{frame}[typeset second]
  This text is shown on the left and on the right.
  \only<second>{This text is only shown on the right.}
  \only<second:0>{This text is only shown on the left.}
  This text is shown on the left. The right shows the same as for the
  previous frame.
\begin{frame}[typeset second]
  \alt<second>{The \string\alt command is useful for second
    mode. Let’s show the table of contents, here: \tableofcontents}
  {Here comes some normal text for the first slide.}
share|improve this question
Your example code compiles OK in my system. Perhaps you are using some outdated package(s)? – Gonzalo Medina Jun 6 '11 at 0:28
I was also able to compile the document without a problem – Vivi Jun 6 '11 at 0:40
@Gonzalo Yes, I was using TeXLive 2007, but have now upgraded to the 2010 version. It compiles correctly. I'd put this as the answer now but I can't self-answer for another 4 hours. Thanks! – Andrew Buss Jun 6 '11 at 3:11
@Gonzalo: Please turn your comment plus the OP's reply into an answer. – lockstep Jun 12 '11 at 18:16
@lockstep: done. I, however, am not sure if the answer makes much sense as it is now. If you have any suggestion to improve it, I'll gladly accept it. – Gonzalo Medina Jun 12 '11 at 18:57

The example code compiled as expected in my system, so perhaps Andre was using an outdated TeX Live system. This was confirmed and the problem was solved, as can be seen in this quote taken from his comment:

Yes, I was using TeXLive 2007, but have now upgraded to the 2010 version. It compiles correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.