Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using pdfpages to include a cover made in Inkscape into a PDF. The PDF has transparent objects.

When building with pdflatex, the transparency is kept in the final PDF, but when I build with xelatex, I lose the transparency in the final PDF.

My cover PDF is http://r.pinson.free.fr/calvary/pdf/cover_fr.pdf

and a MWE is the following:

\documentclass{scrbook}    
\usepackage{pdfpages}
\begin{document}
\includepdf{cover_fr.pdf}
\end{document}

which generates http://r.pinson.free.fr/calvary/pdf/test_pdftex.pdf with pdflatex and http://r.pinson.free.fr/calvary/pdf/test_xetex.pdf with xelatex.

Am I missing an option? Is there a better way to include PDFs in XeTeX, or should I maybe convert it to a PNG instead?

Edit: I mean a gradient, not transparency. The original PDF has a yellow gradient behind the word "ou", which does not appear in the PDF generated with XeTeX.

Note: When I build, I have the following warnings:

** WARNING ** Version of PDF file (1.5) is newer than version limit specification.

Maybe I should export the PDF as 1.4 from Inkscape before importing it with XeTeX?

share|improve this question
    
Redraw it in Tikz! –  Seamus Jun 6 '11 at 21:24
1  
@Seamus: that's an option I have considered, but it would take muuuch longer ;-) Maybe I should try the Tikz export plugin for Inkscape... –  ℝaphink Jun 6 '11 at 21:26
    
It might be me, but I really didn't see any difference in the two pdfs you attached to your question... –  henrique Jun 6 '11 at 23:18
    
I cannot see any transparency in your pdf cover_fr.pdf –  Herbert Jun 7 '11 at 5:52
    
@henrique, @Herbert: the yellow circle behind "ou" has a gradient that doesn't show with XeTeX but shows with PDFLaTeX. –  ℝaphink Jun 7 '11 at 6:13
show 9 more comments

1 Answer

up vote 1 down vote accepted

I regenerated the PDF in Inkscape using PDF 1.4 and it fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.